locked
Running from application from Run

    Question

  • I noticed something when you run an application from Run for example "CMD" it's supposed to run with full admin rights, but by some reason it's not doing so we have to right click and run as administrator. Is than an issue or is it working as designed?
    Microsoft MVP - Windows Expert (IT Pro)
    Thursday, October 13, 2011 3:49 PM

Answers

  • On Windows Developer Preview, when you launch an app through the Run dialog, it will not be launched as elevated unless you have UAC disabled.  Since you mentioned you don't see UAC disabled through Control Panel, I am assuming that on Windows 7, you have used gpedit.msc to disable Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options > User Account Control: Run all adminstrators in Admin Approval Mode.  If you do the same on Windows Developer Preview, then applications will be launched elevated through the run dialog.

    Does this answer your question?

    Thursday, October 13, 2011 9:23 PM

All replies

  • I don't believe that running applications from the run menu will launch them with admin rights.  Perhaps you had UAC turned off on your previous Operating System.
    Thursday, October 13, 2011 6:02 PM
  • But if you look the the description"This task will be created with administrative privileges"

     


    Microsoft MVP - Windows Expert (IT Pro)
    Thursday, October 13, 2011 6:29 PM
  • Was this screen shot taken on a machine with Windows Developer Preview? I am asking this because I don't see this behavior on my machine with Windows Developer's Preview installed, and my explorer windows don't have rounded corners like the one shown in the screenshot. 

    Can you also check Control Panel > System Security > Action Center > Change User Account Control Settings for your machine to see you have UAC disabled?

    Thursday, October 13, 2011 7:56 PM
  • Was this screen shot taken on a machine with Windows Developer Preview? I am asking this because I don't see this behavior on my machine with Windows Developer's Preview installed, and my explorer windows don't have rounded corners like the one shown in the screenshot. 

    Can you also check Control Panel > System Security > Action Center > Change User Account Control Settings for your machine to see you have UAC disabled?

    No actually. It's from Windows 7 i don't have access to Windows 8 rite now. I have UAC turn on. So is this changed on Windows 8?

    Microsoft MVP - Windows Expert (IT Pro)
    Thursday, October 13, 2011 8:05 PM
  • On Windows Developer Preview, when you launch an app through the Run dialog, it will not be launched as elevated unless you have UAC disabled.  Since you mentioned you don't see UAC disabled through Control Panel, I am assuming that on Windows 7, you have used gpedit.msc to disable Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options > User Account Control: Run all adminstrators in Admin Approval Mode.  If you do the same on Windows Developer Preview, then applications will be launched elevated through the run dialog.

    Does this answer your question?

    Thursday, October 13, 2011 9:23 PM
  • On Windows Developer Preview, when you launch an app through the Run dialog, it will not be launched as elevated unless you have UAC disabled.  Since you mentioned you don't see UAC disabled through Control Panel, I am assuming that on Windows 7, you have used gpedit.msc to disable Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options > User Account Control: Run all adminstrators in Admin Approval Mode.  If you do the same on Windows Developer Preview, then applications will be launched elevated through the run dialog.

    Does this answer your question?

    I'll test it and let you know.

    Microsoft MVP - Windows Expert (IT Pro)
    Thursday, October 13, 2011 10:09 PM
  • I just want to add this so incase you run into issues with running Metro Apps.  Metro applications require UAC to be enabled, doing what I suggest above may cause issues when trying to launch Metro applications.

    Thursday, October 13, 2011 10:44 PM
  • If I may make a suggestion:

     

    If you want to run an application as an administrator - using your examples (such as gpedit.msc or even CMD) try the following:

     

    In the metro UI - just type cmd then RIGHT CLICK on it. Next, you will see the advanced option to the bottom right - click on that and choose run as administrator. Same for gpedit.msc which runs as an admin by default.

     

    The run prompt - you don't need it with the METRO UI.

     

    If you want the command window or any other application to be part of the main start menu - PIN IT - then you will always have it available to you quickly without having to type anything. Now you can right click the pinned item and click on advanced to run as administrator.

    =-Chris

     

     

     


    Friday, October 14, 2011 3:28 AM
  • If I may make a suggestion:

     

    If you want to run an application as an administrator - using your examples (such as gpedit.msc or even CMD) try the following:

     

    In the metro UI - just type cmd then RIGHT CLICK on it. Next, you will see the advanced option to the bottom right - click on that and choose run as administrator. Same for gpedit.msc which runs as an admin by default.

     

    The run prompt - you don't need it with the METRO UI.

     

    If you want the command window or any other application to be part of the main start menu - PIN IT - then you will always have it available to you quickly without having to type anything. Now you can right click the pinned item and click on advanced to run as administrator.

    =-Chris

     

     

     


    Yes Mate. I know that how to do that. I just wanted to know if we can elevate directly from Run window. It would make a good option because most of the apps we start from run needs admin rights. On windows 7 I had created shortcuts using task scheduler to auto elevate it without UAC prompt. I guess I have to do the same on WDP as well.

     


    Microsoft MVP - Windows Expert (IT Pro)
    • Edited by CaptainMVP Friday, October 14, 2011 4:11 PM
    Friday, October 14, 2011 4:10 PM
  • But if you look the the description"This task will be created with administrative privileges"

     


    Microsoft MVP - Windows Expert (IT Pro)
    I can't see the run box as a app on start on windevpre8,how would you bring it up..?
    Spanner..
    Friday, October 14, 2011 9:31 PM
  • If you have a keyboard attached, you can use Win+R key to launch the run dialog. Otherwise you can do a search for "Run" in Metro UI and it will pop up as an App in the result list.

    Friday, October 14, 2011 9:38 PM