none
Websitepanel and Mailenable

    Question

  • Server 2008 R2, WSP 1.2.1, Mailenable 4.26. Application pool is 32bit

    I`ve got a problem with WSP

    System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.IO.FileLoadException: Could not load file or assembly 'WebsitePanel.Providers.Base, Version=1.2.0.0, Culture=neutral, PublicKeyToken=da8782a6fc4d0081' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMarkHandle stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName, ObjectHandleOnStack type)
    at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName)
    at System.RuntimeType.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)
    at System.Type.GetType(String typeName)
    at WebsitePanel.Providers.HostingServiceProviderWebService.get_Provider()
    at WebsitePanel.Server.ServiceProvider.Install()
    --- End of inner exception stack trace ---
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at WebsitePanel.Providers.ServiceProvider.Install()
    at WebsitePanel.EnterpriseServer.ServerController.InstallService(Int32 serviceId)
    at WebsitePanel.EnterpriseServer.esServers.InstallService(Int32 serviceId)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at WebsitePanel.EnterpriseServer.esServers.InstallService(Int32 serviceId)
    at WebsitePanel.Portal.ServersEditService.btnUpdate_Click(Object sender, EventArgs e)

    Wednesday, September 5, 2012 9:57 AM

Answers

  • Quick update:

    Solution was to Delete WSP Server module --> Re-install it

    In combination with Mail enable:

    1) Create a new Application pool set it to 32Bit with the same app pool user was filled in with WSP Server setup

    2) Create a new Website with the newly created Application pool and point it to c:\Websitepanel\Server --> With binding 9004

    3) Add a new server to WSP Portal with port 9004 --> Select mailenable (and configure the ip etc)

    4) Create a Virtual server With all resources added BUT using the Newly added "Mail enable server" (running on port 9004) for Mail services

    That sorted the whole issue (and some other 64/32bit related issues)


    Key4ce - IT professionals: www.key4ce.eu

    Wednesday, September 5, 2012 12:36 PM
    Moderator

All replies

  • Hello,

    "WebsitePanel.Providers.Base, Version=1.2.0.0," --> this seems like your WSP Server is still version 1.2.0

    Did you make sure that all WSP Servers are also updated to 1.2.1? (including the one on the MailEnable server?)

    Regards,

    Marco


    Key4ce - IT professionals: www.key4ce.eu


    Wednesday, September 5, 2012 10:03 AM
    Moderator
  • Server version 1.2.1

    Server

    Status: Running
    Version: 1.2.1
    URL: http://127.0.0.1:9003

    ASP.NET Mode:

    If I right understand you

    32-bit

    • Edited by Snoooopy_dog Wednesday, September 5, 2012 10:10 AM
    Wednesday, September 5, 2012 10:09 AM
  • Alright..

    Well i would strongly recommend to check ALL WSP components (if it's a WSP installation on multiple servers --> check out ALL servers too).

    The assembly mis match seems to be a mis match in WSP Versions .. so a component somewhere (on some server if you got multiple servers) is out of date OR didn't updated properly.

    is WSP installed on 1 server? or is Mailenable (and WSP Server) on a different server then the Portal/Enterprise?


    Key4ce - IT professionals: www.key4ce.eu

    Wednesday, September 5, 2012 10:14 AM
    Moderator
  • yes WSP installed on 1 server, and there is the Mailenable
    Wednesday, September 5, 2012 10:16 AM
  • Alright..

    Then please check that Portal + Enterprise on the WSP Server is updated to 1.2.1

    and then go to the Mailenable server --> check that WSP Server component is also updated to 1.2.1


    Key4ce - IT professionals: www.key4ce.eu

    Wednesday, September 5, 2012 10:17 AM
    Moderator
  • I checked. Portal, Enterprise and Server updated to 1.2.1

    Wednesday, September 5, 2012 10:21 AM
  • Is it possible that you can provide me with a portal login for serveradmin ?

    (if so mail it to: m.tiggelaar (at) key4ce.eu)

    Regards,

    Marco


    Key4ce - IT professionals: www.key4ce.eu

    Wednesday, September 5, 2012 10:22 AM
    Moderator
  • Sorry, I don`t have this capability

    Wednesday, September 5, 2012 10:37 AM
  • It's alright,
    have replied by mail. let me know if our RDP is a good solution for you.. and will talk on Skype :-)

    (then once fixed will post the solution here)


    Key4ce - IT professionals: www.key4ce.eu

    Wednesday, September 5, 2012 10:42 AM
    Moderator
  • Quick update:

    Solution was to Delete WSP Server module --> Re-install it

    In combination with Mail enable:

    1) Create a new Application pool set it to 32Bit with the same app pool user was filled in with WSP Server setup

    2) Create a new Website with the newly created Application pool and point it to c:\Websitepanel\Server --> With binding 9004

    3) Add a new server to WSP Portal with port 9004 --> Select mailenable (and configure the ip etc)

    4) Create a Virtual server With all resources added BUT using the Newly added "Mail enable server" (running on port 9004) for Mail services

    That sorted the whole issue (and some other 64/32bit related issues)


    Key4ce - IT professionals: www.key4ce.eu

    Wednesday, September 5, 2012 12:36 PM
    Moderator