none
Absurd error "Error 10: Argument 1 Array must not be empty." RRS feed

  • Question

  • Hi,

    I'm new to ML Studio but I'm really getting crazy with the error in this subject.

    My test experiment on flights delay prediction is perfectly compiled and returns a nice accuracy (nearly 99% on 270K samples).

    However when I publish as a web service (which works) and try to use it, "sometimes" it return the error above.

    However, other times it perfectly works!!

    I don't know if this is the reason, however if I just run an online test and set a parameter to any value between -3 and +3, it works. Instead, if it is 4 or higher (either in positive or negative), the error appears. Since that information just represents the "time in departure", you can imagine that's likely more than 4 (mintues). Anyway I don't catch why I get it, since I never get this error in my experiment even if I run thousand of experiments rather than 1, most of which DO have a value higher than 3.

    Thank you very much for any hint.

    Mauro

    Error Message: Score Model (AFx Library) : Error 10: Argument 1 Array must not be empty.
    Site Path: /subscriptions/b7b2c9e5-8168-4d67-af4f-92602f66ac49/resourceGroups/mauromiMLgrp/providers/Microsoft.MachineLearning/webServices/mauromiFlightPre.2018.8.18.15.43.4.822/test
    Activity ID: dbe7d222-99a9-4a6b-98c0-4577aabb0cfa
    Request ID: 36daaeb5-f11f-41ec-9806-822cd1dafc00
    Workspace ID: e74059d25ab4454798264aecda0ccb03
    Subscription ID: b7b2c9e5-8168-4d67-af4f-92602f66ac49
    Workspace Type: PaidStandard
    User Role: Owner
    Tenant ID: 72f988bf-86f1-41af-91ab-2d7cd011db47


    mauro

    Saturday, August 18, 2018 4:05 PM

All replies

  • Hi,

    For this issue, you need to check your input dataset, there should be no cell is NA or blank.

    Regards,

    Yutong

    Thursday, August 23, 2018 10:46 PM
    Moderator
  • Hi Mauro,

    Sorry about the issue you are encountering. If the data is not confidential, would you be able to publish a sample experiment that generates the error to gallery in unlisted mode? We could take a look.

    Thank you, Ilya

    Friday, August 24, 2018 11:30 PM