locked
how to prevent deploying ASPNETdb.mdf in visual studio 2010 RRS feed

  • Question

  • User-1121540557 posted

    Hi All,

    I`ve a website that i want to deploy, but it failes because it need to access the ASPNETDB.mdf..

    I`m totaly confused, because i`ve deleted this file, but every time i try to publish the website, visual studio add`s the ASPNETDB.mdf to the app_data directory

    Does anybody knows how i can stop this in visual studio 2010? or atleast stop visualstudio trying to deploy the aspnetdb?

     

    Best regards,

    Mark

    Wednesday, December 21, 2011 8:22 AM

Answers

  • User-718146471 posted

    Are you using the asp.net web configuration tool? Also, you have to tell it to build the schema, otherwise it will give you an error. (autogenerateschema="true")

        <membership>
          <providers>
            <clear/>
            <remove name="AspNetSqlMembershipProvider"/>
            <add name="AspNetSqlMembershipProvider" autogenerateschema="true"  type="System.Web.Security.SqlMembershipProvider" connectionStringName="AspNetLocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" requiresUniqueEmail="False" maxInvalidPasswordAttempts="4" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="2" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, December 21, 2011 9:30 AM
  • User-718146471 posted
    Ok, it could be in one other place, machine.config could be pointing at it. That file can be found under (on your local system)
    C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\
    Open the file Machine.Config with notepad or visual studio and comment out this line:

        <add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient" />

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, December 21, 2011 12:33 PM

All replies

  • User-718146471 posted

    Are you trying to use ASP.NET Membership services? Because if you are, I think that is the default database it includes for membership management. You have to tell asp.net that you want to use your production database to hold the membership table information, otherwise it will always include that in your deployment.

    Wednesday, December 21, 2011 8:28 AM
  • User-1121540557 posted

    Hi BBcompent,

     

    Thanks for you quick response!

    Yes i`m using the membership service.

    Hoi can i tell asp.net to use my production database? (In 2008 i never had this problem)

    Best regards,

     

    Mark

    Wednesday, December 21, 2011 8:41 AM
  • User-718146471 posted

    In a similar posting, that can be done this way (see post below)

    http://forums.asp.net/post/4729655.aspx

     

     

    Wednesday, December 21, 2011 8:52 AM
  • User-1121540557 posted

    The post is unavailable...

    Wednesday, December 21, 2011 8:55 AM
  • User-718146471 posted

    Sorry, url poster here is wierd. Try this one: http://forums.asp.net/post/4729655.aspx

    Wednesday, December 21, 2011 9:00 AM
  • User-1121540557 posted

    Hi bbcompent,

    Link is giving me the same result...(The page you are looking for is not available...)(It`s exactly the same link)

    Wednesday, December 21, 2011 9:03 AM
  • User-718146471 posted

    Ok, what I was trying to get to show was this:

     

    Ok, what you need is to add a connection string to the Membership Provider. Put this in where your connection string block is:

    <add name="SQLServerMembershipProvider" connectionString="Server;Database=yourdb;User=youruser;Password=yourpassword;" providerName= />
    Wednesday, December 21, 2011 9:07 AM
  • User-718146471 posted

    Sorry forgot the part for teh provider name:

    <add name="SQLServerMembershipProvider" connectionString="Server;Database=yourdb;User=youruser;Password=yourpassword;" providerName="System.Data.SqlClient" />

    Wednesday, December 21, 2011 9:10 AM
  • User-1121540557 posted

    Still don`t understand you completly..

     

    here is my code..from the config

     

        <membership>
          <providers>
            <clear/>
            <remove name="AspNetSqlMembershipProvider"/>
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="AspNetLocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" requiresUniqueEmail="False" maxInvalidPasswordAttempts="4" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="2" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>

    What must i do then when you remove the connectionstringName and replace it with a connectionstring?

    Wednesday, December 21, 2011 9:12 AM
  • User-718146471 posted

    Ok, under connection strings, you add this (point at your production database):

    <addname="AspNetSqlMembershipProvider"connectionString="Server;Database=yourdb;User=youruser;Password=yourpassword;" providerName="System.Data.SqlClient" />

    Wednesday, December 21, 2011 9:14 AM
  • User-1121540557 posted

    You mean this?(That is what i always had...and is giving me now this publish problem)

     <connectionStrings>
        <add name="AspNetLocalSqlServer" connectionString="Data Source=(local);DataBase=BisSolAuthorization;Uid=User;Pwd=*******"/></connectionStrings>
    Wednesday, December 21, 2011 9:20 AM
  • User-718146471 posted

    Are you using the asp.net web configuration tool? Also, you have to tell it to build the schema, otherwise it will give you an error. (autogenerateschema="true")

        <membership>
          <providers>
            <clear/>
            <remove name="AspNetSqlMembershipProvider"/>
            <add name="AspNetSqlMembershipProvider" autogenerateschema="true"  type="System.Web.Security.SqlMembershipProvider" connectionStringName="AspNetLocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" requiresUniqueEmail="False" maxInvalidPasswordAttempts="4" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="2" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, December 21, 2011 9:30 AM
  • User-1121540557 posted

    Ok, i`ve done it all, but still visualstudio is trying to atach the aspnetdb...and it is giving me the error "The proces connot access the file"C:\..." it`s being used by another process"...

    Wednesday, December 21, 2011 9:38 AM
  • User-718146471 posted

    Then you can simply remove it from the "App_Data" folder where this database file is located and also remove the line in the web.config file that references to it.

    Wednesday, December 21, 2011 9:42 AM
  • User-718146471 posted

    Make sure you stop the local web server debugger to release the hold on the file.

    Wednesday, December 21, 2011 9:42 AM
  • User-1121540557 posted

    Everytime when i remove the App_Data folder and i publish the website visualstudio add`s the App_Data folder with the aspnetdb automaticly...there is also no reference in the config file to the App_Data folder..

    And when i publish the website, the debugger is off..

    So i`m stil having feath that you have a solution for this crasy problem...

    Wednesday, December 21, 2011 9:46 AM
  • User-1121540557 posted

    For some reason it has been publisht now...still visual studio atach the aspnetdb again in the App_Data Folder..

    So if anyone knows how to solve this.....Laughing

    Wednesday, December 21, 2011 11:43 AM
  • User-718146471 posted

    Ok, post your web config with the secret bits cleared out so I can see if you have any references to it.

    Wednesday, December 21, 2011 12:07 PM
  • User-1121540557 posted
    <configuration>
      <configSections>
        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
              <!--  <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
                     <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/> 
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
              <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>-->
            </sectionGroup>
          </sectionGroup>
        </sectionGroup>
      </configSections>
      <connectionStrings>
        <remove name="LocalSQLServer"/>
        <clear/>
        <add name="LocalSQLServer" connectionString="Data Source=(Local);DataBase=BisSolAuthorization;Uid=usrUser;Pwd=******" providerName="System.Data.SqlClient"/>
        <add name="XDb1Conn" connectionString="Provider=SQLOLEDB;Data Source=(local);Initial Catalog=XDb1" providerName="System.Data.OleDb"/>
        <add name="XDb2" connectionString="Data Source=(local);Integrated Security=SSPI;Initial Catalog=XDb2;Integrated Security=True" providerName="System.Data.SqlClient"/>
        <add name="XDb3" connectionString="Provider=SQLOLEDB;Data Source=(local);Integrated Security=SSPI;Initial Catalog=XDb3" providerName="System.Data.OleDb"/>
      </connectionStrings>
      <system.web>
        <compilation debug="true">
          <assemblies>
            <add assembly="Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="Microsoft.Office.Interop.Word, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C"/>
            <add assembly="Microsoft.Office.Interop.Owc11, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C"/>
            <add assembly="Microsoft.Office.Tools.Word, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="Office, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C"/>
            <add assembly="stdole, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="Microsoft.Office.Interop.Excel, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C"/>
            <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="Microsoft.SqlServer.DTSRuntimeWrap, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="Microsoft.SqlServer.ManagedDTS, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="Microsoft.SqlServer.Management.Sdk.Sfc, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="Microsoft.SqlServer.Smo, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="Microsoft.SqlServer.SmoExtended, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="Microsoft.SqlServer.Exec80PackageTask, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="Microsoft.SqlServer.ExecProcTask, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="Microsoft.SqlServer.ConnectionInfo, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845DCD8080CC91"/>
            <add assembly="System.Web.Extensions.Design, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="Microsoft.Office.Tools.Common.v9.0, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="Microsoft.Office.Tools.Common2007, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="Microsoft.Office.Tools.v9.0, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
          </assemblies>
          <buildProviders>
            <add extension=".rdlc" type="Microsoft.Reporting.RdlBuildProvider, Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
          </buildProviders>
        </compilation>
        <authentication mode="Forms">
          <forms loginUrl="~/Account/Login.aspx" timeout="2880" enableCrossAppRedirects="false"/>
        </authentication>
        <authorization>
          <allow users="*"/>
          <!--<deny users="?"/>-->
        </authorization>
        <machineKey decryption="AES" validation="SHA1" decryptionKey="blabla" validationKey="blabla"/>
        <siteMap enabled="true" defaultProvider="SecuredSiteMapProvider">
          <providers>
            <clear/>
            <add name="SecuredSiteMapProvider" type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="web.sitemap" securityTrimmingEnabled="true"/>
            <!-- <add name="AtriclesProvider" type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="Articles/web.sitemap" securityTrimmingEnabled="true"/>-->
          </providers>
        </siteMap>
    
        <membership>
          <providers>
            <clear/>
            <remove name="AspNetSqlMembershipProvider"/>
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="LocalSQLServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" requiresUniqueEmail="False" maxInvalidPasswordAttempts="4" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="2" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>
        <profile>
          <providers>
            <clear/>
            <remove name="AspNetSqlProfileProvider"/>
            <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="LocalSQLServer" applicationName="/"/>
          </providers>
        </profile>
        <roleManager enabled="true" cacheRolesInCookie="true" cookieName=".ASPXROLES" cookieTimeout="30" cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true" cookieProtection="All" createPersistentCookie="false">
          <providers>
            <clear/>
            <add connectionStringName="LocalSQLServer" applicationName="/" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider"/>
            <add applicationName="/" name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider"/>
          </providers>
        </roleManager>
        <healthMonitoring enabled="true">
          <eventMappings>
            <add name="/Event" type="System.Web.Management.WebBaseEvent" startEventCode="0" endEventCode="10000"/>
          </eventMappings>
          <bufferModes>
            <add name="/Buffer" maxBufferSize="100" maxFlushSize="50" maxBufferThreads="1" regularFlushInterval="00:10:00" urgentFlushInterval="00:01:00" urgentFlushThreshold="10"/>
          </bufferModes>
          <providers>
            <add name="/Provider" type="System.Web.Management.SqlWebEventProvider" connectionStringName="LocalSQLServer" buffer="true" bufferMode="/Buffer"/>
          </providers>
          <rules>
            <add name="/Rule" eventName="/Event" provider="/Provider"/>
          </rules>
        </healthMonitoring>
        <pages>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          </controls>
        </pages>
        <httpHandlers>
          <remove verb="*" path="*.asmx"/>
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </httpHandlers>
        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </httpModules>
      </system.web>
      <system.net>
        <mailSettings>
          <!--<smtp>
            <network host="mail.domain.nl" port="25" userName="email@domain.com" password="******"/>
          </smtp>-->
          <smtp deliveryMethod="Network" from="email@domain.com">
            <network defaultCredentials="false" host="smtp.domain.com" port="25" userName="email@domain.com" password="******"/>
          </smtp>
          <!-- <smtp>
            <network host="smtp.domain.com" port="25" userName="email@domain.com" password="******"/>
          </smtp>-->
        </mailSettings>
      </system.net>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true">
          <remove name="ScriptModule"/>
          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </modules>
        <validation validateIntegratedModeConfiguration="false"/>
        <handlers>
          <remove name="WebServiceHandlerFactory-Integrated"/>
          <remove name="ScriptHandlerFactory"/>
          <remove name="ScriptHandlerFactoryAppServices"/>
          <remove name="ScriptResource"/>
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </handlers>
      </system.webServer>
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v3.5"/>
            <providerOption name="WarnAsError" value="false"/>
          </compiler>
          <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v3.5"/>
            <providerOption name="OptionInfer" value="true"/>
            <providerOption name="WarnAsError" value="false"/>
          </compiler>
        </compilers>
      </system.codedom>
      <runtime>
        <assemblyBinding appliesTo="v2.0.50727" xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
      <appSettings>
        <add key="RS2005.ReportService2005" value="http://lt/ReportServer/ReportService2005.asmx"/>
      </appSettings>
    </configuration>
    Wednesday, December 21, 2011 12:16 PM
  • User-718146471 posted
    Ok, it could be in one other place, machine.config could be pointing at it. That file can be found under (on your local system)
    C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\
    Open the file Machine.Config with notepad or visual studio and comment out this line:

        <add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient" />

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, December 21, 2011 12:33 PM
  • User-1121540557 posted

    Top! Thanks bbcompent! (It was Framework 4.0)

     

    Best regards,

    Mark

    Wednesday, December 21, 2011 12:45 PM