none
Unable to find the User Named Account Name@Domain Name while Configuring Workflow Manager RRS feed

  • General discussion

  • Hi,

    I have installed Work Flow Manager,Service Bus and its Cumulative Updates.

    While Configuring Workflow Manger using Workflow Manager configuration wizard i am getting the error while creating a Service Bus Namespace.

    I have provided the Service Accounts for both Workflow Manager and Service Bus as Domain\Account instead of Account@Domain.

    While looking in to the Power Shell scripts that are poupulated by the GUI i have identified that Account@Domain is appended to the ManageUsers switch while creating a Service Bus Namespace and the GUI configuration is failing.

        New-SBNamespace -Name 'WorkflowDefaultNamespace' -AddressingScheme 'Path' -ManageUsers 'Domain\Account','Account@Domain' -Verbose;

    So i need to modify the Powershell script as below and need to run the Powershell scripts for configuring Workflow Manager.

    Is this a bug in GUI Workflow Configuration Wizard or am i doing something wrong.

    Please help.

        New-SBNamespace -Name 'WorkflowDefaultNamespace' -AddressingScheme 'Path' -ManageUsers 'Domain\Account' -Verbose;

    Scripts Populated from GUI modified for Making it working:

    # To be run in Workflow Manager PowerShell console that has both Workflow Manager and Service Bus installed.

    # Create new SB Farm
    $SBCertificateAutoGenerationKey = ConvertTo-SecureString -AsPlainText  -Force  -String 'Run As Password' -Verbose;


    New-SBFarm -SBFarmDBConnectionString 'Data Source=Server Name;Initial Catalog=SbManagementDB;Integrated Security=True;Encrypt=False' -InternalPortRangeStart 9000 -TcpPort 9354 -MessageBrokerPort 9356 -RunAsAccount 'Domain\Account' -AdminGroup 'Domain\Domain Group' -GatewayDBConnectionString 'Data Source=Server Name;Initial Catalog=SbGatewayDatabase;Integrated Security=True;Encrypt=False' -CertificateAutoGenerationKey $SBCertificateAutoGenerationKey -MessageContainerDBConnectionString 'Data Source=Server Name;Initial Catalog=SBMessageContainer01;Integrated Security=True;Encrypt=False' -Verbose;

    # To be run in Workflow Manager PowerShell console that has both Workflow Manager and Service Bus installed.

    # Create new WF Farm
    $WFCertAutoGenerationKey = ConvertTo-SecureString -AsPlainText  -Force  -String 'Run As Password' -Verbose;


    New-WFFarm -WFFarmDBConnectionString 'Data Source=Server Name;Initial Catalog=WFManagementDB;Integrated Security=True;Encrypt=False' -RunAsAccount 'Domain\Account' -AdminGroup 'Domain\Domain Group' -HttpsPort 12290 -HttpPort 12291 -InstanceDBConnectionString 'Data Source=Server Name;Initial Catalog=WFInstanceManagementDB;Integrated Security=True;Encrypt=False' -ResourceDBConnectionString 'Data Source=Server Name;Initial Catalog=WFResourceManagementDB;Integrated Security=True;Encrypt=False' -CertificateAutoGenerationKey $WFCertAutoGenerationKey -Verbose;

    # Add SB Host
    $SBRunAsPassword = ConvertTo-SecureString -AsPlainText  -Force  -String 'Run As Password' -Verbose;


    Add-SBHost -SBFarmDBConnectionString 'Data Source=Server Name;Initial Catalog=SbManagementDB;Integrated Security=True;Encrypt=False' -RunAsPassword $SBRunAsPassword -EnableFirewallRules $true -CertificateAutoGenerationKey $SBCertificateAutoGenerationKey -Verbose;

    Try
    {
        # Create new SB Namespace
        New-SBNamespace -Name 'WorkflowDefaultNamespace' -AddressingScheme 'Path' -ManageUsers 'Domain\Account' -Verbose;

        Start-Sleep -s 90
    }
    Catch [system.InvalidOperationException]
    {
    }

    # Get SB Client Configuration
    $SBClientConfiguration = Get-SBClientConfiguration -Namespaces 'WorkflowDefaultNamespace' -Verbose;

    # Add WF Host
    $WFRunAsPassword = ConvertTo-SecureString -AsPlainText  -Force  -String 'Run As Password' -Verbose;


    Add-WFHost -WFFarmDBConnectionString 'Data Source=Server Name;Initial Catalog=WFManagementDB;Integrated Security=True;Encrypt=False' -RunAsPassword $WFRunAsPassword -EnableFirewallRules $true -SBClientConfiguration $SBClientConfiguration -EnableHttpPort  -CertificateAutoGenerationKey $WFCertAutoGenerationKey -Verbose;


    Thanks, Vijay Arockiasamy

    Wednesday, February 11, 2015 3:49 AM

All replies

  • Hi Vijay

    uninstall this and install the one labeled Refresh 1


    Kind Regards,

    John Naguib

    Senior Consultant

    John Naguib Blog John Naguib Twitter

    Please remember to mark this as answered if it helped you

    Wednesday, February 11, 2015 9:03 AM
  • John,

    Sorry for the delayed response.I have uninstalled and installed servera times but still i am facing the same issue.

    The value in the GUI is not reflected in the Power Shell scripts.I need to manually edit.


    Thanks, Vijay Arockiasamy

    Friday, March 13, 2015 2:12 PM