none
Automated SQL cluster install issue with SSIS

    Question

  • So I have a powershell script that does automated clustered SQL installs and works well sans 1 issue.  Basically on the 1st node I am able to set the /ISSVCACCOUNT and /ISSVCPASSWORD command line parameters and the install works fine and SSIS service is setup and ran with the provided AD accounts.

    However, when I go to install on the 2nd node (/ACTION=AddNode) I get an error that states:

    The setting 'ISSVCPASSWORD' is not allowed when the value of setting 'ACTION' is 'AddNode'.

    If I remove /ISSVCACCOUNT and /ISSVCPASSWORD command line parameters from the install it runs fine and adds the node and installs SSIS just fine.  The problem is now that SSIS on the second node is not running under the same authority as the first node.

    My question is why can  /ISSVCACCOUNT and /ISSVCPASSWORD be specified when installing with /ACTION=InstallFailoverCluster but not when adding additional nodes (/ACTION=AddNode)?  Is there anyway around this?  How do I specify the same SSIS service accounts as the initial cluster install on additional nodes?


    Thursday, January 5, 2017 6:46 PM

All replies

  • Hi dereksg,

    We are currently looking into this issue and will give you an update as soon as possible.

    Thank you for your understanding and support.

    Regards,

    Lin


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, January 10, 2017 1:52 AM
    Moderator
  • Please is there a fix for this yet. It is amazing but the documentation here https://msdn.microsoft.com/en-us/library/ms144259.aspx actually states that  /ISSVCACCOUNT and /ISSVCPASSWORD  are required parameters
    Thursday, March 23, 2017 1:19 PM