none
installation error (CM_PROB_NEED_CLASS_CONFIG) for win10 ndis driver RRS feed

  • Question

  • I'm migrating wddk7 ndis driver to wddk10. After installation, setupapi.dev.log shows some error as follows:

    dvi:                               Existing files modified, may need to restart related services.
    sto:                          {Configure Driver Package: exit(0x00000bc3)}
    dvi:                          Restart required for any devices using this driver.
    dvi:                          Install Device: Configuring device (oem23.inf:usb\vid_271f&pid_6700&rev_0100,NusbWifi.ndi.NT). 18:03:55.323
    dvi:                          Install Device: Configuring device completed. 18:03:55.333
    dvi:                          Device Status: 0x01806000, Problem: 0x0 (0x00000000)
    dvi:                          {Restarting Devices} 18:03:55.393
    dvi:                               Start: USB\VID_271F&PID_6700\FASTBOOT
    dvi:                               Device pending start: Device has problem: 0x38 (CM_PROB_NEED_CLASS_CONFIG), problem status: 0x00000000.
    dvi:                          {Restarting Devices exit} 18:03:55.810
    dvi:                     {Configure Device - exit(0x00000000)} 18:03:55.810
    dvi:                     Device Status: 0x01806400, Problem: 0x38
    dvi:                {Install Device - exit(0x00000000)} 18:03:55.810
    dvi:           {Core Device Install - exit(0x00000000)} 18:03:55.810
    dvi:           Waiting for device post-install to complete. 18:03:55.810
    dvi:           Device post-install completed. 18:03:55.980
    dvi:           Device post-install problem: 0x30 (0xC000036B)
    ump:      {Plug and Play Service: Device Install exit(00000000)}
    ndv:      {Install Related Drivers} 18:03:55.980
    ndv:      {Install Related Drivers: exit(0x00000000)} 18:03:55.980
    dvi:      {DIF_NEWDEVICEWIZARD_FINISHINSTALL} 18:03:55.990
    dvi:           Default installer: Enter 18:03:55.990
    dvi:           Default installer: Exit
    dvi:      {DIF_NEWDEVICEWIZARD_FINISHINSTALL - exit(0xe000020e)} 18:03:55.990
    ndv: {Update Driver Software Wizard exit(00000000)}
    

    I have search the "CM_PROB_NEED_CLASS_CONFIG" and "Device Status: 0x01806400, Problem: 0x38". But got no help on Microsoft website.

    What config did I miss in inf or code?

    Tuesday, May 7, 2019 2:09 AM

All replies

  • Does the device stay in this state or is it functional afterwards? This is meant to be an intermediate step where pnp is done with the install and gives the device to the network configuration service to perform the networking related runtime install actions

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 7, 2019 1:55 PM