none
Accessing Docker Host from a remote machine

    Question

  • All,

    I have Docker for Windows 10 installed on my Home Desktop

    ------------------------------------------------------------------------------------------

    C:\Users\rgopi>docker version
    Client: Docker Engine - Community
     Version:           18.09.0
     API version:       1.39
     Go version:        go1.10.4
     Git commit:        4d60db4
     Built:             Wed Nov  7 00:47:51 2018
     OS/Arch:           windows/amd64
     Experimental:      false

    Server: Docker Engine - Community
     Engine:
      Version:          18.09.0
      API version:      1.39 (minimum version 1.24)
      Go version:       go1.10.4
      Git commit:       4d60db4
      Built:            Wed Nov  7 00:56:41 2018
      OS/Arch:          windows/amd64
      Experimental:     false

    ---------------------------------------------------------------------------------------------------

    On my Home Laptop, I installed the Docker CLI using the chocolatey package and the version is 

    Client: Docker Engine - Community
     Version:           18.09.0
     API version:       1.39
     Go version:        go1.10.3
     Git commit:        51668a30

    ---------------------------------------------------------------------------------------------------

    I would like to access and administer the docker host on my Home Desktop from my Home Laptop

    Is there a comprehensive documentation to enable the host for remote access and the client to access a remote host?

    I tried and I couldn't find much help. I tried the below but the daemon crashed when I restarted the service after I updated the daemon.json file.

    https://www.assistanz.com/access-docker-host-remotely/

    Thanks

    rgn


    • Edited by grajee Friday, January 11, 2019 2:36 AM
    Friday, January 11, 2019 2:34 AM

All replies

  • This shall do it

    Friday, January 11, 2019 12:48 PM
  • I enabled the option as you mentioned and opened the port 2375 in "McAfee LiveSafe" firewall settings and tried the below from my Home Laptop but I got the error below 

    --------------  From Home Laptop ----------------

    C:\Users\rgn>docker -H tcp://192.168.1.201:2375 images
    error during connect: Get http://192.168.1.201:2375/v1.39/images/json: dial tcp 192.168.1.201:2375: connectex: 
    A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

    --------------------------------------------------------

    --------------  From HOST  ----------------

    I tried running from the host itself and it went through:

    C:\Users\rgn>docker -H tcp://localhost:2375 images
    REPOSITORY                                 TAG                 IMAGE ID            CREATED             SIZE
    microsoft/windowsservercore                sqlutils            f45fda842dfa        3 days ago          15.7GB
    microsoft/windowsservercore                latest              323a84d99f04        4 weeks ago         11GB

    But I run the same with IP address from the host itself then I get the below error:

    C:\Users\rgn>docker -H tcp://192.168.1.201:2375 images
    error during connect: Get http://192.168.1.201:2375/v1.39/images/json: dial tcp 192.168.1.201:2375: 
    connectex: No connection could be made because the target machine actively refused it.

    What am I missing?

    Thanks,

    rgn

    Saturday, January 12, 2019 1:07 AM
  • I imagine issue have something to do with firewalling between machines rather with Docker. So first step is to uninstall all firewalls from both machines (not just disable but uninstall)
    Saturday, January 12, 2019 4:18 AM