none
.NET 1.1 SP1 will not install RRS feed

  • Question

  • I am so lost that I don't even know whether I am posting this in the right place.

    I am running Windows XP Pro.  All my updates are current, until now.

    I have automatic updates configured to be automatic.  I got the alert that I needed to download and install .NET Framework 1.1 Service Pack 1.  I did so and then selected auto install.  It does through the normal install message about installing 1 of 1 and then I just get the messages:
    The following updates were not installed:
    Microsoft .NET Framework 1.1 Service Pack 1

    I have run through this cycle about a dozen times selecting custom install, turning off Symantec firewall, etc.  It's always the same result.

    Other than continuing to ignore this update for eternity, what can I do to resolve this or get help?

    Thanks,
    Lance
    Friday, November 30, 2007 1:45 PM

Answers

All replies

  • Ditto...  Have the same exact problem.  Found a reference to .NET Framework 1.1 but it is not the same error message. 

     

    Question:  Is it necessary to even have .NET Framework 1.0 anymore?  If no, then the simple solution is to check the box "don't show this update any further" when Windows finds the update.

     

     

    Friday, November 30, 2007 3:38 PM
  • Yep same here having the exact same problem.

    Friday, November 30, 2007 3:43 PM
  • Same problem.  I'm tempted to ignore it forever, but I don't even really know what it does.

    Friday, November 30, 2007 10:55 PM
  • Hi Lancein,

    You can try to use the following steps to get the machine back into a known state and then install things back one by one:

    1. Download the .NET Framework cleanup tool and choose to cleanup the version of the .NET Framework that is causing problems on your system
    2. Download and install the version of the .NET Framework that you cleaned up in step 1 (such as the .NET Framework 1.0, .NET Framework 1.1 or .NET Framework 2.0)
    3. (optional) Download and run the .NET Framework verification tool to double-check that all .NET Framework files are correctly installed
    4. Download and install the desired .NET Framework service pack (such as .NET Framework 1.0 SP3 or .NET Framework 1.1 SP1) by running the setup package directly instead of using Windows Update.  Running it directly will allow the service pack setup to display error dialogs instead of having Windows Update suppress them

    Running these steps should ideally put your machine back into a known good state with the .NET Framework plus a service pack installed. For more details, please visit What to do if other .NET Framework setup troubleshooting steps do not help.

    Hope this helps!

    Thanks!

    Monday, December 3, 2007 3:17 AM
  • I have exactly the same problem.  It just developed with the latest round of Automatic Updates.

     

    While I appreciate your suggestions, this seems like a lot of effort for those of us who do not even know what .NET Framework is, whether we need it at all, etc.  As far as I know, for example, I have NEVER used this program, at least actively.  Consequently, I would appreciate it if you could answer some simple questions:

     

    1.  Do I even need this program?  I am not a developer of software.  I use commercial packages.

    2.  If I don't need it, can I eliminate the problem by simply uninstalling somehow?  Or is it an integral part of Windows that I cannot get rid of?  I did not find this program on the Add/Remove programs list.

    3.  I did not do anything that I know of that would have caused my machine to need to be put back into a "known good state" as far as this program goes.  Frankly, it seems to me like Microsoft "broke" this on my computer as part of the numerous updates.  Shouldn't it be fixed by another update?

     

    Thanks for any help or information.

     

    Chet

    Friday, December 7, 2007 3:41 PM
  • I got this same problem on XP.

     

    All I did was to re-install Framework 1.1 over the existing version and the system then allowed the SP1 to install as well.

    Friday, December 7, 2007 7:53 PM
  • Same thing worked for me on a Sony Vaio PCG-R50SEL that hadn't been updated at all in over a year.

    Details:

    * I temporarily turned off AVG anti-virus' Resident Shield, just in case, as seemed necessary in order to update to XP Service Pack 3 (to get around access permissions problems).

    * I downloaded Microsoft .NET Framework Version 1.1 Redistributable Package, aka dotnetfx.exe, from http://www.microsoft.com/downloads/details.aspx?familyid=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en .

    * I downloaded Microsoft .NET Framework 1.1 Service Pack 1 aka NDP1.1sp1-KB867460-X86.exe, from http://www.microsoft.com/downloads/details.aspx?familyid=A8F5654F-088E-40B2-BBDB-A83353618B38&displaylang=en .

    * I installed both of these.

    * Subsequently, I used Microsoft Update to install the optional component "Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86".

    * I turned AVG Resident Shield back on. 

    * All is well now.
    Tuesday, July 7, 2009 8:03 PM
  • This is the correct answer.
    Monday, October 26, 2009 1:46 AM