none
Server 2008R2 WebDAV / Webfolders Max upload file size too small RRS feed

  • Question

  • I have a server 2008r2 webdav system setup. Unfortunately, the largest filesize I am able to upload from other systems to this system is about 20 mb. I have modified the web.config to change the maxallowedcontentlength to 2147483648, previously I have edited the web.config to add the maxrequestlength to 2097151 and the execution timeout to 3600, still cannot upload more than 20 mb to the system from my xp or 2003 server. It must be stated that I am not certain that I am editing the correct web.config file. The one I am working with is c:\inetpub\wwwroot\web.config. Since my webdav server is under the default website, I assume this is correct. I have reviewed and modified the Applicationhost.config with similar changes as per iis.net recommended with similar changes however no change in the max upload size. I had read that webdav only reads the applicationhost.config on Server 2008r2 systems, however I have not found much information supporting that. I have read that there may be a limitation on the client that is causing this issue. Unfortunately I am not finding much information on this side of things, other than what is available to accommodate Sharepoint, which I do not have. I would be curious to know if there are any parameters that can be changed on the client that might help this situation. If anyone has any information or suggestions, I would appreciate any help that can be provided.
    Wednesday, January 12, 2011 3:04 PM

All replies

  • Change the "Disk space to use" amount in TOOLS/Internet Options/Browing History SETTINGS button/  You are probably set to use a max of 20mb for local cache on your workstation.  Set it to 250MB or up to 1024 MB
    Tuesday, August 23, 2011 2:05 PM