none
HLK Client stuck in Initializing state RRS feed

  • Question

  • We have set up HLK studio + controller in WIndows Server 2012 R2, while setting up clients for testing the clients are stuck in Initializing state. Even if we try to Ready it manually its is stuck in the initializing state. 

    Any details regarding work around for this issue or reason for the same will be helpful.

    Thanks,
    Upender

    Tuesday, September 10, 2019 12:30 PM

All replies

  • Did you ever get this resolved?

    I'm having the same issue.  Clients communicate with HLK Controller and appear within Studio & Manager bug after selecting Ready, the clients stay in the "Initializing" state which never completes.

    Wednesday, February 12, 2020 2:43 AM
  • You might be able to get more detailed information using HLK Manger, selecting "My Machines".  From there you should be able to select the systems in question and get more detail.  You can even try changing the machine state to "Unsafe", then changing it to "Reset" to see if that might clear up any issues
    Thursday, March 5, 2020 3:28 PM
  • Tried this multiple times and no success. Below is the summary and solution that worked for me.

    Short answer: Step 2 below

    I had a test server which (unintentionally) had more than one OS installed (multi-boot). I blew away the drives and reinstalled (a single) OS instance and the issue was resolved; it Initialized to Ready in about 1 sec.

    Long answer:

    I was encountering and initialization failure condition including the 'HostName Unknown' message (but with Domain config) and the solution that worked for me is as follows. 

    I my scenario I had multiple multiple OS installations on two separate arrays on the same server.  Finally I found an HLK troubleshooting statement that this (multi-boot) scenario is Not a supported test configuration and after deleting all arrays and reinstalling (only one) OS the client, the test client now comes out of Initialization and is Ready (and will run tests) from the HLK Studio / Manager.                                                         

    The following was needed but Step 2 below was the key:

    1) Matching HLK for Both Controller and Client

    2) Only One OS installed on the Test System (Client / SUT)

    3) Disable All Firewall and UAC

    4) Controller & Client Joined to same network (Domain or Workgroup)

    5) For Domain config, Client User is authenticated onto the Domain

    6) On Client, Download HLK Client from HLK Controller by going to \\Your HLK Controller\HLKInstall\Client\Setupamd64.exe

    7) On Controller, Refresh and/or Close and Reopen both HLK Manager & Studio

    8) Create System Pool

    9) Move Test System (Client) into newly created System Pool

    10) Right Click on Test System (Client) and 'Change Machine Status' to Ready

    11) Initialization should very briefly occur and change to Ready

    12) Done

    • Edited by b-rona Thursday, March 5, 2020 11:22 PM additional info
    Thursday, March 5, 2020 11:07 PM
  • Yep, Multi-Boot is considered a sin by DTM.  I got hit with the same problem and found that the DTM client would prefer using the DTM client work directory of one of the other drives.  I did try forcing the other partitions to not be mounted, but ultimately gave up when I read the same well hidden blurb about multi-boot.

    However another common cause for a system to not got into the ready state after the DTM client is installed is there being a time difference between the client and the DTM server.

    Along with, having a test system with more then one NIC, and not connecting that test system to the network using the first NIC, which will sometimes allow the test client to enter the ready state but then cause every test to fail
    Friday, March 6, 2020 8:09 PM