locked
Visual Studio error on deploy DEP0500

    Question

  • Hello,

    I got this error every time I try to relaunch my application in debug mode :

    Error : DEP0500 : The folder "C:\Users\[...]\Metro Style Client\Dev\Base\Sources\Metro.Client\bin\Debug\AppX" could not be deleted.
    Access to the path 'C:\Users\[...]\Metro Style Client\Dev\Base\Sources\Metro.Client\bin\Debug\AppX\Controls' is denied.    Metro.Client

    When I start VS, the first run works fine, but all the next runs will throw this error.
    I have to close and restart VS to re-debug my app...

    I first had problem when the sources were stored in a folder in c:\, then I moved them to my personnal folder. It worked fine, but since yesterday the problem occurs again... without changing anything, it just occurs now again...

    When I try to delete the Appx\Controls I receive a "access denied" message, I can't even see the properties of this folder. I'm not the owner of the folder and can't do anything on it.

    for infos : I'm using a domain logon, my user is administrator of the local machine.

    Wednesday, March 14, 2012 10:58 AM

All replies

  • Hi Julien,

    If we create a new project and put it on another driver, does problem happen?

    If you launch the app from debugger, did it terminated? Once this issue happen, we may use the process monitor or task manager to check if the last process is terminated.

    If you lanuch the VS using "Run as administrator", does it work. It can check if the UAC block the debugger for some specific position.

    If you applied some Anti-virus software on your machines, temprory turn it off, sometimes, these kind of software will block the file.

    Hope the suggestion helps.

    Yi 

      


    Yi Feng Li [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, March 15, 2012 8:05 AM
  • I have the same error here ... Any idea to solve it ?


    Jonathan ANTOINE - Découvrez mon livre sur MVVM: http://goo.gl/N6Tmn - http://www.jonathanantoine.com

    Saturday, April 28, 2012 10:06 AM
  • Ok, I think I found out an answer :

    1. Delete the sln files,
    2. Open the main project
    3. Re add the other projects
    4. Enjoy !

    Jonathan ANTOINE - Découvrez mon livre sur MVVM: http://goo.gl/N6Tmn - http://www.jonathanantoine.com

    Saturday, April 28, 2012 11:34 AM
  • From project properties, under debug tab Uncheck "Always Re-install my package" should solve this

    yanal

    Tuesday, May 1, 2012 12:45 PM
  • Download SysInternals Process Explorer and then search for the path that DEP0500 is complaining about.

    Click Find...Handle or DLL...

    Type in something like 'bin\Debug\AppX'

    I find devenv.exe with open file handles to files/folders in bin\Debug\AppX. They should show up both in the Search dialog and in the Lower Pane in Process Explorer.

    Select the File handle(s) and right-click and select Close Handle.

    This works for me. Seems VS is leaving some handles open.

    Saturday, May 5, 2012 11:23 PM
  • Thursday, February 21, 2013 2:49 PM
  • I have tried all of these.  Are there any new options?

    Saturday, June 22, 2013 6:08 PM
  • this is a super annoying bug.. i get it all the time, and only way around it is to restart VS.

    once it starts happening, it never ends.. you'll build/debug.. get the DEP0500, restart VS. 

    over

    and

    over

    and

    over again and again...

    Tuesday, September 3, 2013 7:11 AM
  • Hi did someone solved this?

    I run into the same error.

    Please !

    Monday, February 10, 2014 10:07 AM
  • Try killing ApplicationFrameHost.exe in task manager. This was the process still accessing the files, and killing it fixed it for me.
    Monday, December 22, 2014 10:24 PM