none
USB Function Client Developement WinCE 6.0 RRS feed

  • Question

  • For developing custom USB Function Client driver (IMX51 platform). I am referring standerd serial usb function client driver. I selected usb otg client  and serial support in catalog items. Also changed default client driver in platform.reg file. I built image. Enabled KITL through Boot options and loaded to target. usbfn.dll and serialusbfn.dll not loaded. I disabled KITL and loaded same image to target. I analyzed debug message through hyperterminal usbfn.dll and serialusbfn.dll are loading. My KITL transport set to ethernet. I dont have any idea why KITL clashing with USB Function client driver. Anybody faced this issue. I am using IMX51 EVK.

     

    [HKEY_LOCAL_MACHINE\Drivers\USB\FunctionDrivers]

    "DefaultClientDriver"=-

    "DefaultClientDriver"="Serial_Class"

     

    Friday, February 25, 2011 12:35 PM

All replies

  • Which is the device used by KITL? Maybe you're using RNDIS?
    Luca Calligaris lucaDOTcalligarisATeurotechDOTcom www.eurotech.com Check my blog: http://lcalligaris.wordpress.com
    • Proposed as answer by GSRid Monday, February 28, 2011 7:12 AM
    Friday, February 25, 2011 2:40 PM
  • I am using Ether device for KITL. I provided eboot settings below.


    -----------------------------------------------------------------------------
    Freescale iMX SOC Menu Item
    -----------------------------------------------------------------------------
     [0] IP Address : 199.63.213.32
     [1] Set IP Mask : 255.255.255.0
     [2] Boot Delay : 15
     [3] DHCP : Disabled
     [4] Reset to Factory Default Configuration
     [5] Select Boot Device : NK from SD/MMC
     [6] Set MAC Address : FF-FF-FF-FF-FF-FF
     [7] Format OS NAND Region
     [8] Format All NAND Regions
     [9] Bootloader Shell
     [I] KITL Work Mode : Interrupt
     [K] KITL Enable Mode : Enable
     [P] KITL Passive Mode : Disable
     [S] Save Settings
     [D] Download Image Now
     [L] Launch Existing Flash Resident Image Now
     [E] Select Ether Device : FEC
     [M] MMC and SD Utilities


    kiran reddy
    Monday, February 28, 2011 6:47 AM
  • Hi,

    There might be PinMux issues between Ether Device FEC and USB Function Controller?

    What is the FEC under index [E]?

    There will be option to set Boot device and Debug device to Ethernet. Make sure you select them.

    Also check in USB Function controller the developers might add some code which causes loading USB Function Driver when KITL or ehternet is enable.

    Thank You & Regards,

    GSR

    Monday, February 28, 2011 7:16 AM
  • Hi GSR,

    [E] option provided in boot loader to select  physical medium for transferring image from host pc.

    Usisng it we can set  FEC or USB RNDIS or USB Serial.

    Regards,

    Kiran

     


    kiran reddy
    Monday, February 28, 2011 8:58 AM
  • Hi,

    Have you identified what is preventing USB Function driver from Loading.

    The other way you can approach is

    •  when you enable KITL open NK.bin from VS2005 and see if the USB Function driver DLL is present or not.
    • If its not present then you have to check Platform.bib and .reg settings.

    Thank You & Regards,

    GSR

    Monday, February 28, 2011 9:12 AM
  • Hi GSR,

     I checked files and registry when KITL is on through remote tools. USB Function driver DLL is present. Also regitry drivers\builtin contains USB Function driver entry.

    Regards,

    Kiran


    kiran reddy
    Tuesday, March 1, 2011 4:52 AM
  • Hi Kiran Reddy,

    Have you kept the break point inside the UfnPDD_Init and have you observed that the control comes into that function?

    You can build the OS in debug mode and see what exactly happening. You can perform step debugging in Debug mode.

    The other method is your driver loading and unloading messages are routed to debug output window. You can search for your USBFunction driver inside it. See if it is there or not. If you carefully observe the log you will come to know what is happening

    Thank You & Regards,

    GSR

    Wednesday, March 2, 2011 5:29 AM