locked
report.rpt cannot be loaded RRS feed

  • Question

  • User1079421601 posted

    I have developed an application using asp.net web form. .NET framework 2  and crystal report 10. Some days ago, I have converted the application to framework 4.5 and SAP crystal report 13.5. Now after deployment to the IIS and if frequent hit goes on the report for example 100 request per minutes, I found a problem . There is a message shows 

    report.rpt cannot be loaded. If I reset IIS, Its work fine. It occurs after every 15-20 minutes.

    If I go to event viewer -> application, I get following warning.

    EventId : 1309 Event Category: Web Event

    Message details:

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 14/12/2014 8:27:40 PM
    Event time (UTC): 15/12/2014 4:27:40 AM
    Event ID: 66dd3c98f2544392947ba5bb44a50ad5
    Event sequence: 10
    Event occurrence: 1
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/1/ROOT/Bluechip-1-130630912509410778
    Trust level: Full
    Application Virtual Path: /Bluechip
    Application Path: C:\inetpub\wwwroot\Bluechip\
    Machine name: BLUECHIPAPP

    Process information:
    Process ID: 1948
    Process name: w3wp.exe
    Account name: IIS APPPOOL\ASP.NET v4.0

    Exception information:
    Exception type: NullReferenceException
    Exception message: Object reference not set to an instance of an object.
    at Report.Application.clsReportBase.PFSubReportConnectionMainParameter(String ReportName, ArrayList ParamArraylist, String ReportFolder)
    at Report_ReportHolderPDF.GetReportDocument()
    at Report_ReportHolderPDF.Page_Load(Object sender, EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



    Request information:
    Request URL: http://192.168.20.73/Bluechip/Report/ReportHolderPDF.aspx?sRptName=rpt_portfolio_statement_investor_wise.rpt
    Request path: /Bluechip/Report/ReportHolderPDF.aspx
    User host address: 192.168.20.19
    User: sa
    Is authenticated: True
    Authentication Type: Forms
    Thread account name: IIS APPPOOL\ASP.NET v4.0

    Thread information:
    Thread ID: 10
    Thread account name: IIS APPPOOL\ASP.NET v4.0
    Is impersonating: False
    Stack trace: at Report.Application.clsReportBase.PFSubReportConnectionMainParameter(String ReportName, ArrayList ParamArraylist, String ReportFolder)
    at Report_ReportHolderPDF.GetReportDocument()
    at Report_ReportHolderPDF.Page_Load(Object sender, EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


    Custom event details:

     Please help me, How can I solve the problem?

    Monday, December 15, 2014 12:19 AM

All replies

  • User1759999623 posted

    Have you tried pulling the report into a new version of Crystal Reports?  There may be some incompatibilities in the report structure that can be resolved by upgrading the report itself.

    Monday, December 15, 2014 2:59 AM
  • User1079421601 posted

    Tried with new version of SAP crystal report. Not solved.

    Wednesday, December 17, 2014 2:26 AM
  • User1759999623 posted

    To some extent, it sounds like your credentials are based on the current session.  How are you logging into the report on the production side?

    Wednesday, December 17, 2014 7:59 AM
  • User1079421601 posted

    I don't understand your question clearly? I am logging to the report using database server user name and password.

    Wednesday, December 17, 2014 11:37 PM
  • User1759999623 posted

    Are you using the same credentials in production?  Are you using the same server in report development as in production?

    Thursday, December 18, 2014 9:45 AM