locked
How to manually upload sql server database to azure? RRS feed

  • Question

  • Hi,

    I published my web app onto azure successfully. But since I didn't add my sql server database into the my visual studio solution, the database was not uploaded to the azure.

    When I develop my app, the database was attached to the sql server through ssms, so the connection string is using Initial Catalog rather than the file path.

    Now I want to upload the database not just a database schema. How can I do that?

    Thank you in advance.

    Friday, May 6, 2016 5:41 AM

Answers

  • Hi Swikruti,

    I installed sql server and uploaded the database successfully.

    • Marked as answer by peter 9 Sunday, May 22, 2016 11:08 PM
    Sunday, May 22, 2016 11:08 PM

All replies

  • Hello Peter,

    Thank you for posting here!

    Please try to follow the below steps,

    Open azure portal -> Go to App services -> Choose the application -> Go to Settings -> Data connection -> Click on Add button -> Select Type as SQL Database -> SQL Database Configure require settings and you can choose existing database as below,

    The similar query has been answered in MSDN thread. Please refer the same.

    Hope this helps.

    Regards,

    Swikruti

    If a post answers your question, please click Mark as Answer on that post and Vote as Helpful.

    Friday, May 6, 2016 4:42 PM
  • Hi Swikruti,

    Thank you for your helping.

    I followed your instruction, at the Database pane, I clicked on the existing database, then the area chaned to whole blue area, and cannot work further.

    Then I click on the SQL databases at the main menu on the left hand side, and deleted the existing database.

    After that I click on App Service -> setting -> Data Connections -> click Add button -> click Configure required settings -> create a new database -> filling the Name -> configure required settings -> filling server name, server admin login, password, change the location to Australian east, every thing got green tick, and I click the OK button, a plan blue panel covers the New server area, then nothing happens.
    I click on SQL databases at far left panel, it shows "No sql databases to display".

    I have got no idea now. Would you please help me again? Thank you.

    Monday, May 9, 2016 1:29 AM
  • Hi,

    I have a sql server database (sql server express). I want to upload the database to azure because my azure app needs it.

    I use visual studio 2013 and sql server management studio 2014 (version 12.0.2000.8).

    I read article sql server database migration to sql database in the cloud. (https://azure.microsoft.com/en-us/documentation/articles/sql-database-cloud-migrate/ ). 

    That requires the latest ssms and the latest ssms needs vs2015. So my question is that is there any other way to upload my database to azure?

    Thank you.

    • Merged by Swikruti Bose Wednesday, May 11, 2016 11:49 AM Similar Query
    Wednesday, May 11, 2016 1:03 AM
  • Hello Peter,

    Please try to execute the steps which has been mentioned in this article and let us know the status.

    Hope this helps.

    Regards,

    Swikruti

    If a post answers your question, please click Mark as Answer on that post and Vote as Helpful.
    Wednesday, May 11, 2016 12:25 PM
  • Hi Swikruti,

    Thank you for your helping.

    I am using sql server express 2014 and VS 2013.

    In my SSMS version 2014, it does not have Deploy Database to Microsoft Azure SQL Database… and Import Data-tier Application... functions.

    So I cannot use SSMS migration wizard way and I cannot use BCAPAC way as well.

    Is the problem that I use sql server express version? Is there any other way to do the job? for instance, use ftp to upload database?

    Thank you.

    Friday, May 13, 2016 12:34 AM
  • Hello Peter,

    I would suggest you to create a support ticket for the better assistance.

    Regards,

    Swikruti

    If a post answers your question, please click Mark as Answer on that post and Vote as Helpful.
    Friday, May 20, 2016 10:37 AM
  • Hi Swikruti,

    I installed sql server and uploaded the database successfully.

    • Marked as answer by peter 9 Sunday, May 22, 2016 11:08 PM
    Sunday, May 22, 2016 11:08 PM