locked
Help me to connect RRS feed

  • Question

  • TITLE: Connect to Server

    I have downloaded the sql server express edition 2005 .When i open Sql Server Management Studio i am unable to connect this is the error message Login failed for user 'sa'. (Microsoft SQL Server, Error: 18456)

     

     

    Sunday, July 16, 2006 5:05 PM

Answers

  • hi,

    are you sure this is the exact exception you are reported with, or does the error message say "Login failed for user 'sa'. Reason: Not associated with a trusted SQL Server connection"?

    if this is the case, SQLExpress install by default disabling standard SQL Server authenticated connections.. only WinNT trusted connections will be available.. you can thus connect via a local Windows account member of the local\administrators group, as this group is by default granted login to local SQL Server instances...

    once you are connected, you cane use SQL Server Management Studio to modify this behaviour after install time... you can select the "server"'s properties and, in the "security" tab (ok, it's no longer a tab, but I hope you understand my meaning) and enable "SQL Server and Windows authentication mode".. this will enable mixed security authentication, allowing you to connect with standard SQL Server logins..

    as regard "sa" login, please verify it's property (node Security->Logins) and, in the "status" tab (again, it's no longer a tab :D) check that the login is "enabled"..

    regards

    Sunday, July 16, 2006 7:43 PM

All replies

  • hi,

    are you sure this is the exact exception you are reported with, or does the error message say "Login failed for user 'sa'. Reason: Not associated with a trusted SQL Server connection"?

    if this is the case, SQLExpress install by default disabling standard SQL Server authenticated connections.. only WinNT trusted connections will be available.. you can thus connect via a local Windows account member of the local\administrators group, as this group is by default granted login to local SQL Server instances...

    once you are connected, you cane use SQL Server Management Studio to modify this behaviour after install time... you can select the "server"'s properties and, in the "security" tab (ok, it's no longer a tab, but I hope you understand my meaning) and enable "SQL Server and Windows authentication mode".. this will enable mixed security authentication, allowing you to connect with standard SQL Server logins..

    as regard "sa" login, please verify it's property (node Security->Logins) and, in the "status" tab (again, it's no longer a tab :D) check that the login is "enabled"..

    regards

    Sunday, July 16, 2006 7:43 PM
  • Hi,

    I was able to connect to sql server with local Windows account member of the local\administrators group.now in "server"'s properties and, in the "security" tab which one is  SQL Server and Windows authentication mode"..  I am able to see only the logins

    1. Builtin/Administrator

    2.BUILTIN/Users

    3.Khatri/SQLSERVER2005MSFTEUSER$KHATRI$MSSQLSERVER

    4.Khatri/SQLSERVER2005MSSQLUSER$KHATRI$MSSQLSERVER

    5.NT AUTHORITY\SYSTEM

    6.Sa

    and also i see tht-for all the above login properties , In the status tab permession is grant and login is enabled for all the above,In the general tab i am unable to select any of them as they disabled or out of focus.

    Which one to select?Please help me out

    Thank You

    Amitha.

     

    Monday, July 17, 2006 2:22 AM
  • hi,

    >1. Builtin/Administrator

    >2.BUILTIN/Users

    >3.Khatri/SQLSERVER2005MSFTEUSER$KHATRI$MSSQLSERVER

    >4.Khatri/SQLSERVER2005MSSQLUSER$KHATRI$MSSQLSERVER

    >5.NT AUTHORITY\SYSTEM

    al these are WinNT related logins, used someway with trusted connections...

    you only have

    >6.sa

    as standard SQL Server login...

    after you modify the security setting, you have to restart the service in order standard SQL Server authenticated logins to be granted connection...

    >and also i see tht-for all the above login properties , In the status tab permession is >grant and login is enabled for all the above,In the general tab i am unable to select >any of them as they disabled or out of focus.

    please excuse me, but I'm unable to understand your requirements.. can you please expand on this?

    thank you

    Monday, July 17, 2006 10:39 AM