none
Microsoft Azure Storage Explorer - Unable to retrieve child resources

    Question

  • Hi,

    Many users are experiencing the same issue trying to access their [Blob containers] under [SAS-Attached Services].

    The error is: 

    Unable to retrieve child resources

    Details: The provided connection string

    "BlobEndpoint=https://OneOfOurStorageAccounts.blob.core.windows.net;SharedAccessSignature=" does not have complete configuration settings

    The issue is that we can't replace the connection to this resource by attaching with a new SAS token because it won't allow another connection to the same resource. On the other hand we can't detach the connection to this resource because it can't be retrieved. Is there another way I can change the incomplete configuration settings?

    This is in the latest version of Microsoft Azure Storage Explorer - 0.8.6

    Hope this is the right place for this question.

    Cheers,
    Jared

    Tuesday, December 13, 2016 5:44 AM

Answers

All replies

  • Hello,

    We are checking on the query and would get back to you soon on this. I apologize for the inconvenience and appreciate your time and patience in this matter.

    Regards,
    Sumanth BM

    Tuesday, December 13, 2016 7:40 PM
    Moderator
  • Hi Jared,

    I am a developer in Storage Explorer team. We apologize for the inconvenience. To fix this issue, you need to delete data from "%appData/StorageExplorer" folder from your machine. After deleting, when you launch storage explorer you will be ask to reenter your credentials. That should fix this issue.

    Let me know if you still see the issue.

    Thanks

    Nishant

    Monday, December 19, 2016 6:56 PM
  • Hi Nishant, 

    thanks for the solution, it finally fixed my issue. I had to delete the storageExplorer folder under %appdata/roaming. 

    Regards

    Aykut


    A.Kurtay


    Thursday, January 19, 2017 1:52 PM
  • Hi Jared,

    Your solution didn't fix the issue "Unable to retrieve child resources"
    So I found the issue is caused due to self signed certificate that is found in the certificate store, so when Azure requests the endpoint, the local certificate is used for connection, so this fails in retrieving the child resources.

    Work Around: Check the box to connect the Azure Storage as "http", making sure your host machine is in the safe network and continue to connect. This helps in connecting smoothly.

    Thank You,

    Guruprasad Balaji,
    Microsoft Azure Solutions Specialist.

    Wednesday, August 2, 2017 8:46 AM
  • Thanks for sharing the workaround. It might help others facing a similar issue.

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Thursday, August 3, 2017 10:01 AM
  • Hi Guru,

    I tried both the solution (deleting %appdata% storage folder and the "http" workaround) but still I am facing the same issue.

    Thanks,

    Shalini

    Thursday, September 21, 2017 7:17 AM
  • Hi Jared,

    I tried both the solution (deleting %appdata% storage folder and the "http" workaround) but still I am facing the same issue.

    Thanks,

    Shalini

    Thursday, September 21, 2017 7:18 AM
  • Are you using the latest version of Azure Storage Explorer?

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Wednesday, October 11, 2017 10:01 AM
  • Nishant,

    There is an issue (bug, whatever) with the Storage Explorer.

    The client is case insensitive but not the service in Azure. One must enter the storage name as case SENSITIVE or the enumeration of child objects will fail. 

    Not sure the proper place to report this issue, but hopefully you will see this reply.

    Tuesday, February 6, 2018 11:06 PM
  • @Ricardo Corral: Thanks for reporting this. Could you tell us what version of Azure Storage explorer tool you’re using?

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.
    Thursday, February 8, 2018 6:58 AM
  • Azure Storage Explorer version:

    Version: 0.9.4

    Platform: win32

    Build Number:
    20180119.2

    Commit: 7fad4387

    Support Id:
    9b00a30c-81cc-ba83-19ff-18e284432da2

    Steps:

    Add Connection > Use storage account name and key > Account name

    Symptoms:

    If the 'account name' is not entered using the same casing as it is se within Azure, the Azure Storage Explorer will add the connection normally, but when trying to expand a node (e.g. Blob Containers) an exception will be raised.

    Exception:

    Unable to retrieve child resources.

    Details: One of the request inputs is out of range.
    RequestId:e07c514e-001e-00fc-42f8-a0da97000000
    Time:2018-02-08T16:16:08.3053802Z

    Additional notes:

    The client (Storage Explorer) itself is NOT case sensitive, and it will refuse to add a second connection with the same name regardless the casing of the connection name. The add connection wizard will refuse with a red message "The Microsoft Azure storage account has already been attached"
    Thursday, February 8, 2018 4:17 PM

  • Just wanted to update everyone on this and the next steps. 

    • Bug State: The product team has opened a bug on the case sensitivity issue to improve the user experience such that we can make check before we make a connection.

    • Recommendation: We strongly encourage Storage Explorer users to sign in into Azure to have a more streamlined experiences with Azure Storage.

    • Error Causes: In terms of the “child process” error, this a catch all bucket that can have many causes. The team has fixed all the known ones (except this), so if you still hit the issue, please report in a new post for us to get it investigated. 

    • Timeline: The team is working on this bug and once it is fixed, we will include the info in the release notes for Storage Explorer.

    • History Lesson: We also wanted to give a little history about the current behavior of Storage Explorer.  The current “case insensitivity” in Storage Explorer is by-design, since we need to allow users to enter upper cases for their blob container names. This is because in v1 Azure storage (sometimes called classic Azure storage), there was a period of time the Storage services allowed to use upper case in container names. 
    Thursday, March 1, 2018 5:50 AM
    Owner
  • Deleting didnt work for me. But I think this whole thing happens because I do not have permissions for this storage resource, other storage resources work fine... Maybe you should improve the error message for "no permission".
    Tuesday, September 11, 2018 3:10 PM
  • Can you confirm the storage explorer version ?

    Tuesday, September 11, 2018 6:50 PM
    Moderator
  • Just checking in if you have had a chance to see our previous response.

    Friday, September 14, 2018 5:29 PM
    Moderator