locked
Can run in simulator, but can't deploy app to device in IOS 9 RRS feed

  • Question

  • User159692 posted

    I am running ios9 in the beta channel. I have xcode 7 installed. I've updated my previous 32 bit app to 64 bit. When I run the app against IOS 9 in the simulator it runs just fine. I try to run against my ipad that has IOS 9 release installed and I get this error in the deploy to device window:

    Installing application bundle error MT1006: Could not install the application '/Users/me/MobileApps/myapp/myapp.iOS/bin/iPhone/Debug/myappOS.app' on the device myipad1: AMDeviceSecureInstallApplicationBundle returned: 0xe80000be (kAMDMismatchedApplicationIdentifierEntitlementError). The application was terminated by a signal: SIGHUP

    I have ARMv7 + ARMv7s + ARM64 selected in my supported architectures for my device deploy setting. Linker options are don't link

    Any ideas what would be causing this to not deploy to my device and what this error message means? Thanks in advance.

    Thursday, September 17, 2015 9:59 PM

All replies

  • User128618 posted

    I have the same issue

    Friday, September 18, 2015 11:01 AM
  • User159692 posted

    Has anyone else seen and fixed this issue?

    Friday, September 18, 2015 5:01 PM
  • User159692 posted

    I fixed this issue. I'm not positive the issue, but I had a previous version of the app on my device from the app store. My ios dev account had lapsed so it was renewed. Since there are team members and the ios dev account format looks like it changed a bit it appears there was some kind of conflict there. I just manually deleted the app on my device and I was able to deploy to my device after that.

    Friday, September 18, 2015 6:16 PM
  • User134191 posted

    I had the same issue with an iOS 9 device this morning. Delete app manually via device. Then re-try deployment. That worked for me.

    Wednesday, September 30, 2015 3:43 PM
  • User42276 posted

    Same issue I got today. I just uninstalled old version from device manually and try again. its works fine. :smile:

    Friday, October 16, 2015 1:12 PM
  • User133899 posted

    thanks solved my issue

    Thursday, March 23, 2017 8:51 PM
  • User89714 posted

    @JoeSauve_x - Manually deleting the old app is ok in a development environment, but how do we avoid the equivalent happening with an update to an app in production, where the update is coming from the app store? Don't really want to tell users to manually delete the old version of the app.

    Friday, April 14, 2017 12:51 PM