locked
500 Internal Server Error RRS feed

  • Question

  • User599606961 posted

    Hi Guys,

    I wondered if you can help. I am currently in the process of launching www.veterinaryelite.net. It;s currently live but I'm receving the 500 Internal Server Error. 

    I have uploaded and resorted Database.Bak file. All settings to allow asp.net in terms of programming function capability for the server is activated. I have adjusted the persmissions for the folders where necessary but still receiving this error. 

    I have tried adding the custom error configuration to the web.config file to give me a detailed list of the errors but stil not working. 

    Anyone have any ideas? I have the FTP details if anyone wished to take a look? I'm at a loose end. 

    Thanks, 

    Friday, July 20, 2012 8:26 AM

Answers

  • User1992938117 posted

    <add name="ConnectionString" connectionString="server=xxxx;database=xxxx;uid=xxxx; password=xxxxx" />
    </connectionStrings>

    Its Always suggested don't share any username and password at the Forum. Always use as above notations.

    Also keep your web.config as web.config don't modify it as web.config.txt.

    After changing Name as (web.config) Try to browse using page name:

    http://www.veterinaryelite.net/index.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 20, 2012 9:05 AM
  • User1992938117 posted

    I have changed back to web.config and now receice the 500 internal server error?

    I fixed the issue.

    I did two changes:

    1. Rename Index.aspx to Default.aspx (All references).

    2. Published website using file system then uploaded using FTP.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 20, 2012 12:47 PM

All replies

  • User1992938117 posted

    Have you uploaded and tested html pages? If not then upload any index.html page and test that its working or not.

    Friday, July 20, 2012 8:34 AM
  • User599606961 posted

    Yes, I've just added a index.html page and it works fine. It won't pick up the index.aspx page though? It returns the 500 internal server error 

    Friday, July 20, 2012 8:41 AM
  • User1992938117 posted

    Yes, I've just added a index.html page and it works fine. It won't pick up the index.aspx page though? It returns the 500 internal server error 

    I just tried : http://www.veterinaryelite.net/index.aspx

    and i got error page.

    Update your web.config from:

    <system.web>
            <customErrors mode="Off"/>
        </system.web>

    to:

    <system.web>
            <customErrors mode="RemoteOnly"/>
        </system.web>

    So that we can see the error.

    Friday, July 20, 2012 8:50 AM
  • User599606961 posted

    When the web.config file is saved as a web.config.txt I recieve the error you mentioned. 

    Here is my web.config.txt file; I have made the changes as you suggested but I still receive the same error. 

    <?xml version="1.0"?>

    <configuration>
    <configSections>
    <section name="rewriter" requirePermission="false" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" />
    </configSections>

    <appSettings>
    <add key="WebsiteName" value="Dental Elite" />
    <add key="WebsiteUrl" value="www.dentalelite.co.uk" />
    <add key="SiteURL" value="http://www.dentalelite.co.uk/" />
    <add key="Uploads" value="~\UploadedImages\Images\" />
    <add key="DefaultURL" value="http://www.webcreationuk.com/" />
    <add key="Errors" value="~\UploadedImages\Errors\" />
    <add key="adminMailID" value="paul.wilkinson@dentalelite.co.uk" />
    <add key="ReferralScheme" value="paul.wilkinson@dentalelite.co.uk" />
    <add key="CandidateRegister" value="candidateregistration@dentalelite.co.uk" />
    <add key="Bcc" value="anujg@webcreationuk.com" />
    <add key="PageTitle" value="Dental Elite" />
    <add key="Cvfile" value="../UploadedImages/CVFiles/">
    </add>
    <add key="description" value="Dental Elite are a leading UK-based dental recruitment agency. We specialise in the placing of dentistry professionals right across the sector." />
    <add key="keywords" value="Dental Jobs, Dentist Jobs, Associate Jobs, Locum jobs,Dental Nurse Jobs, Dental Hygienist Jobs, Dental Therapist Jobs, Dental Practice Sales, Buy a Dental Practice, Sell a Dental Practice, Dental Practices for Sales" />
    </appSettings>
    <connectionStrings>
    <add name="ConnectionString" connectionString="server=plesksql2.ehosting.com;database=paulwigoo5699com5607_;uid=dentalpaul; password=paulisanidiot" />
    </connectionStrings>
    <system.web>
    <pages enableViewStateMac="false" viewStateEncryptionMode="Never" enableEventValidation="false">
    <namespaces>
    <add namespace="System.Data" />
    <add namespace="System.Data.SqlClient" />
    <add namespace="System.IO" />
    <add namespace="System.Configuration" />
    <add namespace="ImageProcessor.Drawing" />
    </namespaces>
    </pages>
    <compilation debug="true" >
    <assemblies>
    <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    </assemblies>
    </compilation>
    <system.web>
    <customErrors mode="RemoteOnly"/>
    </system.web>

    <httpRuntime maxRequestLength="20480" executionTimeout="600" />
    <httpHandlers>
    <add verb="GET" path="CaptchaImage.aspx" type="WebControlCaptcha.CaptchaImageHandler, WebControlCaptcha" />
    </httpHandlers>
    <httpModules>
    <add type="Intelligencia.UrlRewriter.RewriterHttpModule, Intelligencia.UrlRewriter" name="UrlRewriter" />
    </httpModules>

    </system.web>

    <system.net>
    <mailSettings>
    <smtp>
    <network host="localhost" />
    </smtp>
    </mailSettings>
    </system.net>
    <rewriter>
    <!-- Redirect non www version to www version -->
    <!--<if header="host" match="^sitename\.co\.uk">
    <redirect url="^(.*)$" to="http://www.sitename.co.uk$1" permanent="true" processing="stop"/>
    </if>-->
    <!--<if url="~/(.+).aspx">
    <rewrite exists="~/$1.aspx" to="~/$1.aspx" processing="stop"/>
    </if>-->
    <rewrite url="~/GetImage/(.+).aspx$" to="~/GetImage.ashx?Params=$1" processing="stop" />
    </rewriter>
    </configuration>

    Friday, July 20, 2012 8:55 AM
  • User1992938117 posted

    <add name="ConnectionString" connectionString="server=xxxx;database=xxxx;uid=xxxx; password=xxxxx" />
    </connectionStrings>

    Its Always suggested don't share any username and password at the Forum. Always use as above notations.

    Also keep your web.config as web.config don't modify it as web.config.txt.

    After changing Name as (web.config) Try to browse using page name:

    http://www.veterinaryelite.net/index.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 20, 2012 9:05 AM
  • User599606961 posted

    Ok no problem. 

    I have changed back to web.config and now receice the 500 internal server error?

    Friday, July 20, 2012 9:10 AM
  • User1992938117 posted

    I have changed back to web.config and now receice the 500 internal server error?

    Yes i have seen.

    Have you checked from control panel that its supports asp.net 3.5 ?

    Just check and if disable then enable .net for iis or website.

    Also check your Inbox (PM)

    Friday, July 20, 2012 9:13 AM
  • User71929859 posted

    Hello,

    500 is general error code. You need to get the sub code of the error (500.xx) and provide more details than this to solve this. Can you copy paste the whole error you are getting?

    Friday, July 20, 2012 9:47 AM
  • User1992938117 posted

    I have changed back to web.config and now receice the 500 internal server error?

    I fixed the issue.

    I did two changes:

    1. Rename Index.aspx to Default.aspx (All references).

    2. Published website using file system then uploaded using FTP.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 20, 2012 12:47 PM
  • User311508580 posted

    Hi Paul,

    What is the full error message that you get?

    Monday, July 23, 2012 12:09 AM
  • User1361645605 posted

    Hi! did you get it working? As I am on the exact same issue. Just testing 1 single page with few controls on it. And getting the same 500 error.

    Sunday, February 10, 2013 4:57 PM
  • User1992938117 posted

    Hi! did you get it working? As I am on the exact same issue. Just testing 1 single page with few controls on it. And getting the same 500 error.

    I solved the issue using below changes:

    http://forums.asp.net/post/5075561.aspx

    If still you are facing issue, let me know!

    Monday, February 11, 2013 12:02 AM
  • User1361645605 posted

    Thanks so much for your reply. I have searched all day yesterday and did not fix this. Nothing I found, which was adding some extra parameters to web.config, helped. I have ASP.Net enabled on my Hosting. I have sent a request to my Hosting so they can see if it is something on their side or on mine. My page is in .NET 4, blank page with 6 controls - just a quick test. Runs fine on my local machine, but shows 500 Error when Published with VS2012 using FTP Publishing.

    http://asppagetest.awardspace.com

    Files in the directory: http://asppagetest.awardspace.com/files.png

     

    Monday, February 11, 2013 1:07 AM
  • User1992938117 posted

    http://asppagetest.awardspace.com

    Its working, I think index.aspx is not set as Default page.

    Monday, February 11, 2013 4:00 AM
  • User1361645605 posted

    Hmm. It does. It was not for all day yesterday and up to about 1 hour ago. But now it works. Strange.

    It seems that my Hosting support did something to my hosting settings as they still did not reply to my Trouble ticket i have opened yesterday. I will let you guys know if my hosting had to do something or it just a 1 day delay in my website updating.

    Monday, February 11, 2013 4:17 AM
  • User1361645605 posted

    So. My website, that I created the simplest way possible - New Website, named main file index.apsx and added few controls. It was absolutely fine on general settings in VS 2012 - the issue was my Hosting and they solved it for me. I have no idea what they did, but it worked. Here is the message i got from them:

    Rajneesh Verma


    Hello Juris
    Thank you for contacting us.
    Our Administrators have fixed the issue and now your website is up and running.
    Feel free to reopen this ticket in case you have more questions or you need further assistance. Thank you for choosing our services.
    Best regards,
    Tailor Hall
    Dedicated Support Team

    So, if someone still has the issue - contact your Hosting and aske them to investigate it - it worked for me!

    Monday, February 11, 2013 7:13 AM