Consuming SVC service getting error RRS feed

  • Question

  • User1858009984 posted

    While Consuming SOAP based  SVC service in Console .Net application, getting the error as "The maximum message size quota for incoming messages (65536) has been exceeded. To increase the quota, use the MaxReceivedMessageSize property on the appropriate binding element".

    Even i increased our maxReceivedMessageSize="2147483647" in config still issue not solved.

    Tuesday, November 20, 2018 5:32 AM

All replies

  • User1120430333 posted

    It depends on what side the client-side or service-side the error is occurring. If it's on the WCF client-side,  then you can do what you are doing above in the client-side config file.

    If it's on the service-side, then you must override the bindings for the service with a 'Custom Binding'  in the service-side config in order to give the new setting.

    Tuesday, November 20, 2018 10:23 AM
  • User-330142929 posted

    Hi Ravindranath M,

    Try to set all restriction to Max number, and apply the binding configuration name to the endpoint.
    Take Webhttpbinding as an example.

    <service behaviorConfiguration="mybehavior" name="WcfService1.Service1">
    <endpoint address="" binding="webHttpBinding" contract="WcfService1.IService1" behaviorConfiguration="webbev" bindingConfiguration="mybinding"></endpoint>
    <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
    <binding name="mybinding" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" sendTimeout="00:10:00" receiveTimeout="00:10:00">
    <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" />
    <security mode="Transport">
    <transport clientCredentialType="None"></transport>

    Feel free to let me know if there is anything I can help with.
    Best Regards

    Wednesday, November 21, 2018 2:54 AM