none
Office Version 7.0.3300.0 in GAC RRS feed

  • Question

  • Hi there, I am getting the following error on other machines after publishing my code:

     

    "Unable to install or run the application. The application requires that assembly Office Version 7.0.33.00.0 be installed in the Global Assembly Cache first. "

     

    So I installed the oxppia and o2003pia and rebooted. I still get the error. I navigated to C:\Windows|Assembly and see Microsoft.Office.Interop.Excel 11.0.0.0 in the folder. Will this not work?

     

    Please let me know!

    Monday, April 5, 2010 5:35 PM

Answers

All replies

  • Hi CoderEgo,

    Thank you for your post.

    Based on your description, it seems that your application is looking for the assembly Office Version 7.0.33.00.0 on the target machine.

    Some clarification with you:
    Does your application refer this assembly?

    If yes, for your concern, please set the property "Copy Local" of this reference to true. This determines whether a reference is copied to the local bin path.
    For more detail information, please check: http://msdn.microsoft.com/en-us/library/t1zz5y8c.aspx
    Does it work?

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, April 13, 2010 1:51 AM
    Tuesday, April 6, 2010 8:59 AM
  • You need the Office 2007 PIAs, not 2003!

    http://msdn.microsoft.com/en-us/library/aa371634(VS.85).aspx 


    Phil Wilson
    • Marked as answer by YiChun Chen Tuesday, April 13, 2010 1:51 AM
    Tuesday, April 6, 2010 6:51 PM
  • You have one or more of two different issues.

    #1: If you are coding against Office 2007 (V12) and the system where you're installing only has Office 2003 (V11), then you should consider "downgrading" your code to reference the Office 2007/V11.  I believe it will still run on a properly-licensed Office 2007 machine.

    #2: The installation of Office (regardless of version) needs to include the .NET Programmability feature, which is DISABLED by default on installation.  Go here and follow these steps: http://msdn.microsoft.com/en-us/library/aa159923(office.11).aspx

    I just had the same issue... this worked for me.  Hope it works for you too.

    Ray

    Monday, May 10, 2010 4:16 PM