locked
ASP.NET Configuration Icon in VWD2008EXPRESS RRS feed

  • Question

  • User-1851576699 posted

    When I am logged on the original Administrator account on my Windows 7 Ultimate computer I get this message when clicking the ASP.NET->Security link in VWD->Solution Explorer

    "There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

    The following message may help in diagnosing the problem: Unable to connect to SQL Server database."

     

    So, I created a second Administrator account on the exact same computer and clicked on the same ASP.NET Configuration icon in VWD2008EXPRESS and finally clicked on the Security.aspx link and it works without fault. The App_Data folder is created in the Solution Explorer and the ASPNETDB.MDF file is created in the App_Data folder.

    Somebody PLEASE tell me why creating a virgin Adminstrator account makes things work the way they should to "begin" with? How can I make 100% absolute sure that my original Administrator account has the required permissions that it needs to use the ASP.NET Configuration->Security.aspx page to create the virgin ASPNETDB.MDF files.

    I am guessing the original Adminstrator account has become corrupt and I need to corrupt it. Please if you can help me with this I need a detailed way to check for proper permissions. Give me detailed steps.

    I've poked around in the registry using REGEDIT, I've looked Adminstrative Tools->Local Security Policy, I've loaded up MMC and used the Snap-In "Local Users and Groups" but I don't know exactly what I am looking for and what I need to do.

    If I can't get this fixed soon I will have no choice but to reformat my computer and reinstall everything. Thanks.

    P.S. I did Install the SQL Server 2008 Express w/Advanced Services initially but I uninstalled it and re-installed SQL Server 2008 Express w/Tools and SP1, if any of this makes a difference.

     

     

     

     

     

    Thursday, April 15, 2010 3:47 AM

Answers