none
.Net Framework-I have different versions installed but none appear in the Registry. RRS feed

  • Question

  • Hi..
    I am currently having problems installing postgresql and Microsoft Visual Basic 2008 Express Edition on Windows Vista.
    I get the following error messages while installing postgresql:
    1.    "Error 1935: An error occurred during the installation of assembly. 'Microsoft .VC80.ATL.type="win32".version="8.0.50727.4053".publicKey Token="1fc8b3b9a1e18c3b".processorArchitecture="x86". Please refer to Help and Support for more information."

    2. "An erro occured executing the Microsoft VC++ runtime installer."

    And when installing VB i hav the following error message:
    "Error occured during setup." "Visual C++ Runtime pre-requisites" could not be installed.

    I have on my computer .Net Framework versions 2.0,3.0,3.5 and 4.0 installed but none appear in the Registry. Could it be that the above-mentioned problems stem from that?
    Friday, February 5, 2010 7:34 AM

Answers

  • ohh..thanks anyway. But i formatted my computer and i could install both programs..

    :)
    • Marked as answer by YiChun Chen Monday, February 8, 2010 9:13 AM
    Sunday, February 7, 2010 7:17 PM

All replies

  • Neither 1 nor 2 are .NET Framework errors (and you don't see it in Programs and Features because it is already part of the OS).

    Both of those messages relate to Visual C++ runtime support (VC++ support is treated as an assembly when installed on Vista).  I would make sure that you are doing these installs from an elevated command prompt. Yes, I know you'll say you're an administrator but unless you see an elevation prompt you won't be running as an administrator ;=)
    Phil Wilson
    Friday, February 5, 2010 9:49 PM
  • ohh..thanks anyway. But i formatted my computer and i could install both programs..

    :)
    • Marked as answer by YiChun Chen Monday, February 8, 2010 9:13 AM
    Sunday, February 7, 2010 7:17 PM