none
Microsoft .NET Framework installation RRS feed

  • General discussion

  • I have Windows XP installed and am trying to get Microsoft .NET Framework 3.5 installed from Microsoft's website.  Do I need to Uninstall previous versions of Microsoft .NET Framework?

    When I try and install it, I get the following message: 

    [09/16/08,19:33:05] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [09/16/08,19:35:32] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
    [09/16/08,21:35:28] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [09/16/08,21:37:41] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
    [09/16/08,21:57:43] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [09/16/08,21:59:49] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.


    Any help would be greatly appreciated.

    Thursday, September 18, 2008 12:33 AM

All replies

  •  

    Hello,

           I don’t think previous version of Microsoft .NET Framework should be removed before we install .NET Framework 3.5.    Of course, if the version of .NET Framework is some pre-release or Beta version, we’d better uninstall all these Beta versions before we install some new RTM versions of .NET Framework.

            If you have some Beta versions of .NET Framework installed, please use this cleanup tool to uninstall them at first.  

            Or if the installation issue still exists, you know the error code 1603 means some fatal error during the installation process.   We could not tell the exact reason of the failure only through this error code and some more detail information will be very helpful to troubleshoot the root cause here.   Thus, would you please use this collection utility to get the setup and error log files to us?   Upload the file %TEMP%\vslogs.cab to some server and offer us the URL.    You could sign up for 5GB free space at http://skydrive.live.com only with your Live Passport.  

     

            Also, if you have any other questions, please just let me know.

     

             Thanks,

     

    Best Regards,

    Lingzhi


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/csharpide/thread/8e9ed0d7-11ff-402a-8489-9b5f05eeb706 http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Friday, September 19, 2008 7:36 AM
    Moderator
  •  

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/csharpide/thread/8e9ed0d7-11ff-402a-8489-9b5f05eeb706 http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Wednesday, September 24, 2008 8:55 AM
    Moderator