locked
Android emulator not working RRS feed

  • Question

  • User383560 posted

    I'm getting this error for some reason and i'm getting how to resolve this: Project cannot build using Android 8.1 (API Level 27 - Oreo) because You are using OpenJDK, and this version of Java is not supported by Xamarin.Android. Please install Oracle Java. Please install it or set Java Development Kit path for Oracle 1.8+ on Tools->Options->Xamarin->Android Settings menu.

    I have Android studio installed and the virtualdevices there are working properly. I have enabled hyperv I have also installed HAXM as I keep getting popup saying I should install it in visual studio (Even without this above error was there.)

    I have no clue as to how I can resolve this. If anyone has answer to this please help me here.

    Thanks,

    Friday, November 1, 2019 6:54 AM

All replies

  • User388988 posted

    Are you getting this error when compiling or when you load the app to the device? Check out the location of the openJdk of your project. You can see it at tools>options>Xamarin>Android configurations (sorry if there something different, I'm using the portuguese version).

    What you can do also is to download the openJdk 8 found at: https://jdk.java.net/java-se-ri/8 I've tried the jdk 13, but it didn't worked for me, what worked was the version 8. You unzip and change the jdk location at visual studio.

    About the emulation you have to use or hyperv or the HAXM, you can't use both at the same time for what I have tested. I don't have experience using hyperv, I'm currently using HAXM and it's working fine. I had to disabled hyperv to get it working, but if your emulator is working I don't thing you should have a problem with this.

    Hope this works.

    Monday, November 4, 2019 1:38 PM