none
Visual Studio 2015 Professional Not Responding for minutes RRS feed

  • Question

  • For a few weeks/months now, I am experiencing very frequent 'Visual Studio Not Responding' problems.  My Visual Studio 2015 Professional (Version 14.0.2543.01 Update 3) frequently hangs for about 7 to 10 minutes, which is quite annoying and reduces my productivity.  This typically happens a few seconds or minutes after startup and loading of the solution file.  After it happened, I can continue using it without any new hangs, until I close it and start it again.  It also happens with very simpel solution files.

    I tried solving the problem by uninstalling and reinstalling VS2015, but that didn't help (although I didn't completely remove the C:\Program Files (x86)\Microsoft Visual Studio 14.0 folder after I uninstalled).

    I've used PerfView to create a PerfViewData.etl.zip file as follows:

    PerfView.exe collect /zip:true /nogui /threadtime:true /AcceptEULA

    The result can be downloaded from here:

    https://drive.google.com/open?id=1EPmCYpu0bNzrrBRn3N4XQlpCsaHyQOtn

    I have no clue where to start looking in order to solve this problem.  Can anyone help me out here?

    Wednesday, September 5, 2018 8:51 AM

All replies

  • I'm using community 2017 and I didn't encounter this problem. Maybe try the most basic way - restarting your computer? (I have no clue what's happening too)
    Wednesday, September 5, 2018 9:54 AM
  • Hi Bart Vandewoestyne,

    Thank you for posting in MSDN forum!

    Does this issue happened for loading the specific project type or any project types?

    According your description, please check the following steps to troubleshoot your issue:

    1. Delete Solution user Option file ( .suo file ) in .vs folder, the .vs folder is a hidden folder at the *.sln folder level.
    2. Clear all folders and files under the folder: %LocalAppData%\Microsoft\VisualStudio\15.0\ and restart the VS 2015 to check it again.
    3. Try running devenv.exe /Safemode to see if you can apply it correctly. This can eliminate the possibility that third party Add-ins or packages are causing problems;
    4. Run VS installer, choose “Repair” button and repair VS.

    Let me know if any of those worked with you.

    Best Regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, September 6, 2018 9:00 AM
    Moderator
  • Thanks for your suggestions. I will try them all, one by one, and report back.

    However, just to be sure, for (2) I assume you mean %LocalAppData%\Microsoft\VisualStudio\15.0\ since we're dealing with VS2015 here?

    Kind regards,
    Bart

    Thursday, September 6, 2018 11:32 AM
  • Hi Bart Vandewoestyne

    Thank you for your response.

    In Visual Studio 2015, you could go to %LocalAppData%\Microsoft\VisualStudio\14.0\ and perform above steps.

    Best Regards,

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, September 10, 2018 5:45 AM
    Moderator
  • Oops, yes, I indeed meant %LocalAppData%\Microsoft\VisualStudio\14.0\  Sorry for the confusion.

    In the meanwhile, I have tested the following options:

    1. Delete Solution User Option file.
    2. Clear all folders and files under %LocalAppData%\Microsoft\VisualStudio\14.0\.
    3. Run VS2015 in Safe Mode using devenv.exe /SafeMode

    None of the above three options fixed the problem.  I still get a VS2015 with more than 6 minutes 'Not responding' right after I started it up and start coding.  I will try the last solution (Repair) later and report back here.


    Monday, September 10, 2018 11:34 AM
  • Hi Bart Vandewoestyne,

    Is there any update about your issue?

    If you have got it, could you please share your solution here which will be helpful for those who has the similar issue with you? Thank you for understanding.

    BTW, if you have any VS IDE issue in the future, you can contact us and we do our best to help you.

    Best Regards,

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, September 14, 2018 3:18 AM
    Moderator
  • Is there an official fix for this issue yet? Im encountering exactly the same problem as Bart
    Saturday, May 25, 2019 3:58 PM
  • Do you have an SSD hard drive?  The faster file transfer times prevents a lot of hangs.  

    Do you have any extensions?  If you do disable them and see if that prevents the hangs.

    Saturday, May 25, 2019 5:11 PM
  • Since my recent update to VS-2019, I'm getting similar problems!

    Often, when changing a solution's "Configuration" the program just gets stuck (no response for ages - have to kill it with Task Manager). Seems to happen most often when switching from "x64" to "x86" config (the latter uses the "v141_xp" build tools).

    Also, sometimes the text editor (C++ source files) starts getting progressively slower and slower then VS2019 just restarts itself (sometimes with no 'recovery' of files).

    Just installed the latest (16.2.1) update but the problem still occurs.

    Really annoying,

    Adrian

    PS: I'm using a big solution (18 projects, mixed DLL/EXE/LIB and utility) with lots of configs and 4 platforms - could this be a problem?

    Tuesday, August 6, 2019 9:09 PM
  • I think I figured it out.

    Visual Studio produces thousands of SQM files in a directory : c:\Users\<your user>\AppData\Local\Microsoft\VSCommon\14.0\SQM

    At some parts of its processing ( when it seems to be hanging ) it does a lot of writes / reads to files in that directory. When there is 70K+ files, its very slow since the OS is not efficient at accessing files in such large directories.

    There is another process, on a scheduler, that is supposed to send these files out, but I suspect, they forgot to make it delete the sent files.

    You can stop the creation and r/w of most of these files as follows:


    https://www.ghacks.net/2016/10/26/turn-off-the-windows-customer-experience-program


    ( I used the group policy and local regedit methods)

    Once I set it to Enabled! (not Disabled - note the double negative), and rebooted, the sqm files stopped being created, and Visual Studio  no longer locks up for 6 - 18 minutes.

    You can also block just visual studio from participation in the experience improvement program by going to the menu Help | Send Feedback | Settings -> and there choose the 'No, I would not...' radio button.

    I also removed my old SQM folder (had over 70K files) , and created a new one which only has a few files in it. With every run of VisualStudio , only about 2 or 3 files are added even though I did all of the above. But 2 files per run are not a big deal, compared to the 70K I accumulated over about 4 months.

    Peter




    • Edited by peterparl Friday, August 9, 2019 2:01 PM
    Wednesday, August 7, 2019 3:59 PM
  • Did you try the method I described below (removing SQM files and blocking windows user experience features)?


    Friday, August 9, 2019 1:58 PM