locked
Back navigation causes combobox navigation menu to stop funtioning RRS feed

  • Question

  • I have a row of dropdown menus in a navigation bar at the top of my page that function without issue from the main page.  The problem occurs when I navigate away from the page.  When I click the back button, all of my dropdown stop working.  All other buttons on the page still function normally.  Here is the code for the dropdown:

                    <ComboBox x:Name="OurPrograms" BorderThickness="0" BorderBrush="{x:Null}" Width="145" SelectedIndex="0" FontSize="16" Style="{StaticResource ComboBoxStyle3}" Height="40" Canvas.Left="135" Canvas.Top="1">
                        <ComboBox.Background>
                            <LinearGradientBrush EndPoint="0.5,1" StartPoint="0.5,0">
                                <GradientStop Color="Black" Offset="0.987"/>
                                <GradientStop Color="White" Offset="1"/>
                            </LinearGradientBrush>
                        </ComboBox.Background>
                        <ComboBoxItem>
                            <HyperlinkButton Content="   Our Programs" NavigateUri="http://www.insuranceshopllc.com/insurance/programs/" Foreground="Black"/>
                        </ComboBoxItem>
                        <ComboBoxItem>
                            <HyperlinkButton Content="Pay As You Go Work Comp" NavigateUri="http://www.insuranceshopllc.com/insurance/programs/pay-as-you-go-work-comp.htm" Foreground="Black"/>
                        </ComboBoxItem>
                        <ComboBoxItem>
                            <HyperlinkButton Content="Pay As You Go GL" NavigateUri="http://www.insuranceshopllc.com/insurance/programs/pay-as-you-go-gl.htm" Foreground="Black"/>
                        </ComboBoxItem>
                        <ComboBoxItem>
                            <HyperlinkButton Content="Payroll and Insurance Services" NavigateUri="http://www.insuranceshopllc.com/insurance/programs/payroll-insurance-services.htm" Foreground="Black"/>
                        </ComboBoxItem>
                        <ComboBoxItem>
                            <HyperlinkButton Content="Office Insurance" NavigateUri="http://www.insuranceshopllc.com/insurance/programs/office-insurance.htm" Foreground="Black"/>
                        </ComboBoxItem>
                        <ComboBoxItem>
                            <HyperlinkButton Content="Small Contractors Insurance" NavigateUri="http://www.insuranceshopllc.com/insurance/programs/contractors-insurance.htm" Foreground="Black"/>
                        </ComboBoxItem>
                        <ComboBoxItem>
                            <HyperlinkButton Content="Insurance By State" NavigateUri="http://www.insuranceshopllc.com/states/" Foreground="Black"/>
                        </ComboBoxItem>
                    </ComboBox>

     

    Any ideas as to why this is occurring, or how to avoid this issue?

     

    Thanks,

    Chriss

    Wednesday, October 19, 2011 4:27 PM

Answers

  • Do to the lack of response after 265 views, I have switched the dropdown menu from xaml to use a css dropdown, nullifying the issue.

    Thanks,

    Chriss

    • Marked as answer by Chriss N Wednesday, November 23, 2011 9:40 PM
    Wednesday, November 23, 2011 9:40 PM