locked
Ribbon loading endlessly on IE9 RRS feed

  • Question

  • Hi,

    I use SharePoint 2010 and i have an issue with the ribbon in my List View. This problem seems to be well known but none of the solution I used correct it.

    I add a search web part on my list view and the ribbon didn't show for one user browser (IE9). I removed it (as suggested in this topic : http://social.msdn.microsoft.com/Forums/sharepoint/en-US/8dc4c060-4e7b-4977-b5c8-34a555cdaa89/missing-ribbon?forum=sharepointgeneralprevious) and the top ribbon appears but loading endlessly (no function available). It's happend only for one user, others can see the full ribbon. I checked the browser configuration and everything seems to be ok.

    Any suggestion for this issue?

    Thanks

    Tuesday, May 13, 2014 8:50 AM

Answers

  • Try using Fiddler. Check the .JS scripts the clicking on the last loaded element in the LEFT window and then on the RIGHT click on Inspectors then Headers on the top of the window and Text View on the bottom of the window.  You are probably getting Access Denied on one or more scripts in the /_Layouts folder.

    If your site has an anonymous component you might have accidentally blocked necessary scripts when locking down your site.

    If this is the case open your web.config and look for location elements that include the layouts folder path. This example below would cause the behavior you are describing.

      <location path="_layouts">
        <system.web>
          <authorization>
            <deny users="?" />
          </authorization>
        </system.web>
      </location> 

    http://social.technet.microsoft.com/Forums/en-US/05d97030-440d-4ca0-b5d1-6914507a06d1/sharepoint-2010-ribbon-stuck-at-loading?forum=sharepointadminprevious

    Also try 

    http://sharepointconnoisseur.blogspot.in/2013/04/tips-to-resolve-sharepoint-2010-ribbon.html

    • Marked as answer by David Dh Tuesday, May 13, 2014 10:02 AM
    Tuesday, May 13, 2014 8:55 AM

All replies

  • Try using Fiddler. Check the .JS scripts the clicking on the last loaded element in the LEFT window and then on the RIGHT click on Inspectors then Headers on the top of the window and Text View on the bottom of the window.  You are probably getting Access Denied on one or more scripts in the /_Layouts folder.

    If your site has an anonymous component you might have accidentally blocked necessary scripts when locking down your site.

    If this is the case open your web.config and look for location elements that include the layouts folder path. This example below would cause the behavior you are describing.

      <location path="_layouts">
        <system.web>
          <authorization>
            <deny users="?" />
          </authorization>
        </system.web>
      </location> 

    http://social.technet.microsoft.com/Forums/en-US/05d97030-440d-4ca0-b5d1-6914507a06d1/sharepoint-2010-ribbon-stuck-at-loading?forum=sharepointadminprevious

    Also try 

    http://sharepointconnoisseur.blogspot.in/2013/04/tips-to-resolve-sharepoint-2010-ribbon.html

    • Marked as answer by David Dh Tuesday, May 13, 2014 10:02 AM
    Tuesday, May 13, 2014 8:55 AM
  • I will have a closer look to the /_Layouts folder because there is an Access Denied for one script reported by Fiddler. 

    Thank you for the tips!

    Tuesday, May 13, 2014 10:02 AM