locked
Visual Studio 2012 Update 2 - LightSwitch HTML 5 Client RRS feed

  • Question

  • Got to say the install experience for Visual Studio Update 2 has been terrible. Due to constraints at work I have to download the packages for offline installation by running the exe with the /layout switch and it took forever to download with many errors occurring. I resorted to looking in the log files as described in Unable to locate package source. When downloading Visual Studio 2012 Update 2 and downloaded packages manually before recommencing the update.

    I have applied this update to my dev workstation (Win7 Ent SP1, 64bit) with Visual Studio 2012 Update 1 already applied. (Visual Studio 2011 SP1 and Visual Studio LightSwitch 2011 are also installed.)

    I attempt to create a new LightSwitch HTML Application (Visual C#) and I get a popup error dialog stating "The method or operation is not implemented."

    I also attempt to follow the HTML 5 client tutorial for Contoso Moving (from LightSwitch HTML Client Tutorial - Contoso Moving) and when after adding the HTML client application I am unable to select any screen data when adding a new screen to the HTML client. The screen data drop down in the Add New Screen dialog does not contain any entries other than the default (None).

    When I view the upgrade log for ContosoMoving it refers to running upgrade component V2UpgradeComponents.v2.6.xxx (Upgrades the LightSwitch v2 xxx project from HTML Client Preview 2.) I have never applied any HTML Client Preview to this workstation.

    Please advise how to fix these issues.


    Friday, April 19, 2013 4:41 PM

All replies

  • If you have LS 2011 installed on your computer, remove it and start over on the conversion from VS 2012 Upd 1.

    You do NOT have to remove VS 2010 - just LS 2011.   Reboot after your removal.

    There is also an Update Project menu item that will update your app without creating an HTML5 project.

    I expect we'll here more about this.

    Advice to all:   Frequently backup your source code.


    Garth Henderson - Vanguard Business Technology

    Friday, April 19, 2013 5:21 PM
  • Hi Garth,

    Thanks for the prompt reply. (Guess you realised I meant VS2010 and not VS2011!)

    Will do this on Monday when back at work and will report on progress.

    Have a good weekend.

    Friday, April 19, 2013 7:57 PM
  • Hi Garth,

    I've tried the above and this does not resolve the issue. Same errors occur.

    I've even gone as far as uninstalling Update 2, Visual Studio LightSwitch 2012 Extensibility Toolkit, Visual Studio 2012 SDK, Visual Studio 2012 and then reinstalling. Same errors occur.

    Any other ideas?

    Monday, April 22, 2013 1:49 PM
  • A colleague has just installed Visual Studio 2012 Update 2 to a machine which has never had LightSwitch 2011, nor any HTML Client Preview nor Update 2 CTP installed.

    He observes the same error on creating a new HTML Client LightSwitch application.

    Monday, April 22, 2013 3:30 PM
  • Do you have your application(s) running on VS 2012 Upd 1 on another computer?

    Did you run the Update Project with VS 2012 Upd 2?

    If you create a new project with VS 2012 Upd 2, it will automatically be a V3 project.

    Please confirm that you are still not able to create a project with an extension.

    A good extension to test with is Yann's LS Controls:

    Luminous LightSwitch Controls

    I have verified that they work.

    I downloaded the Contoso Moving example from:

    LightSwitch HTML Client Tutorial - Contoso Moving

    I ran the Upgrade Project on the example:

    There were no problems with the upgrade:

    The app compiled and ran fine.

    Next, I created the HTMLClient for the app.

    Yes, I got THE ANNOYING temp directory problem - that was introduced in Upd 1 and still not fixed in Upd 2:

    • Error 1 An exception occurred when building the database for the application.
      An error occurred while establishing a connection to SQL Server instance '(LocalDB)\v11.0'.
      Could not open new database 'C:\9HTMLEXAMPLES\CONTOSO\VB\CONTOSOMOVING\BIN\DATA\TEMP\APPLICATIONDATABASE.MDF'. CREATE DATABASE is aborted.
      An attempt to attach an auto-named database for file C:\9HTMLExamples\Contoso\VB\ContosoMoving\Bin\Data\Temp\ApplicationDatabase.mdf failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share.
      File activation failure. The physical file name "C:\9HTMLExamples\Contoso\VB\ContosoMoving\Bin\Data\Temp\ApplicationDatabase_log.ldf" may be incorrect.
      The log cannot be rebuilt when the primary file is read-only.   The user 'GCAADS\Administrator' does not have permission to modify the database.  Permission granted by a security group is not sufficient.  The user must be granted modify permissions on 'C:\9HTMLExamples\Contoso\VB\ContosoMoving\Bin\Data\Temp'.  For additional details see: http://go.microsoft.com/fwlink/?LinkId=245794 C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\LightSwitch\v3.0\Microsoft.LightSwitch.targets 152 6 ContosoMoving

    This is a known bug with the workaround to manually change the security for the users to full control for the temp directory.

    I got a compile with no errors.   I added 1 state and 2 customers in the app under Create Sample Data.

    I created a browse screen for the Customers with the HTML client.  Absolutely no problems.

    You should be able to do the same thing.

    Please confirm.


    Garth Henderson - Vanguard Business Technology


    Monday, April 22, 2013 6:04 PM
  • Apologies for not being clear in my previous reply. I appreciate the time you are taking to diagnose this issue. I am not sure why you refer to existing apps on Visual Studio 2012 Update 1 - the issues observed seem to be entirely associated with HTML Client applications which are only available with Update 2.

    Platform - Win7 Ent 64bit SP1

    Previously had installed in order (IIRC):

    • Visual Studio 2010, Visual Studio 2010 SP1, Visual Studio LightSwitch 2011, Visual Studio 2010 SDK, Visual Studio LightSwitch 2011 Extensibility Toolkit.
    • (Various extensions)
    • Visual Studio 2012, Visual Studio 2012 SDK, Visual Studio LightSwitch 2012 Extensibility Toolkit.
    • (Various extensions), Visual Studio 2012 Update 1, Visual Studio 2012 Update 2

    I have since uninstalled Visual Studio LightSwitch 2011 and Visual Studio 2011 Extensibility Toolkit.

    I have repaired Visual Studio 2012 Update 2. The same issues occur:

    • When creating a new LightSwitch HTML Application - an error popup stating "The method or operation is not implemented."
    • After adding the HTML Client to the Contoso Moving sample, the screen data drop down in the Add New Screen dialog does not contain any entries other than the default (None).

    I have uninstalled Update 2, uninstalled Visual Studio 2012, reinstalled Visual Studio 2012 and reinstalled Update 2 and the errors still occur.

    I have repeated combinations of uninstall / install, repair, unistalling extensions and I must admit I've lost a bit of discipline as I now observe a slightly different error for the Contoso Moving project where I do not get either the option to upgrade nor add the HTML client.

    I am also unable to create a LightSwitch HTML application when running Visual Studio in safemode (to rule out interference from any extensions) as I get an error dialog stating "'D:\Playpen\Application8\Application8\Application8.ls3proj' cannot be opened because its project type (.ls3proj) is not supported by this version of the application. To open it, please use a version that supports this type of project.

    <pulling what little hair i have left out>

    Tuesday, April 23, 2013 4:34 PM
  • Hey Aargh,

    I assumed that you were upgrading apps.

    It sounds like you are doing everything right.

    Do you happen to have Resharper installed?

    We can screenshare if you like.  I am in Hawaii (GMT-10).  Email:  garthh at Vanguardok.com


    Garth Henderson - Vanguard Business Technology

    Tuesday, April 23, 2013 5:39 PM
  • Hi Garth,

    Thanks for the offer. Unfortunately my work environment prevents me from taking up your offer. We have a tight constraints with regard to access to the internet from the network on which my dev workstation resides - basically no access to the internet.

    I do not have resharper installed (I have seen other posts referring to Visual Studio extensions interfering - which is why I have resorted to uninstalling pretty much all extensions, then attempting to run in safemode though why a Microsoft visual studio update project type (.ls3proj) would not be supported in safemode is beyond me).

    Do you or anybody else have any other ideas?

    Do you recommend raising a support ticket with Microsoft? I will report on progress back here.

    Thanks for all the help / advice so far.

    Tuesday, April 23, 2013 6:38 PM
  • Yes, I recommend that you open a ticket.  

    I currently have an open ticket for migration issues.  


    Garth Henderson - Vanguard Business Technology

    Tuesday, April 23, 2013 6:51 PM
  • I have opened a ticket with Microsoft - ID is 785467.

    (Also edited my profile - my name is Rob rather than Aaaaaaaaaargh - moment of frustration.)

    Wednesday, April 24, 2013 10:46 AM
  • I am having the same issue on one of my machines. Was a solution found? Do I need to install VS2012, Update 1 and then Update 2?

    Thanks

    Jay 


    Jay Turpin

    Wednesday, May 15, 2013 3:23 PM
  • Thanks for the reports Jay and Rob.

    Rob, I have been the one on your ticket trying to get a repro for the problem and still haven't had any success in reproducing the issue.

    Jay, Update 2 contains all of the bits that Update 1 contained so you shouldn't need to install both, just Update2 should be sufficient.

    Jay on the machine that you are seeing the problem on what do you have installed other than VS2012? I am trying to see if there is some commonality between the systems that you and Rob are running that might point me towards a consistent repro.

    Thanks,

    Kris


    Kris Langohr | Senior SDET | LightSwitch QA

    Wednesday, May 15, 2013 5:13 PM
  • Hi Kris - thanks for the update - I look forward to receiving any feedback when you are able to diagnose the issue.

    Hi Jay - glad(?) I'm not the only one. Hope that this can be resolved.

    Thursday, May 16, 2013 8:24 AM
  • Kris - I'm pretty sure I installed the HTML Client Preview on both machines. On both machines, I uninstalled VS2012, Resharper and anything else seemingly related to VS, Lightswitch and web development.

    I reinstalled VS2012 and Update 2. On one box, I am able to create both types of Lightswitch C# projects and add the other type of client to the project. But on one box, I still get the  "The method or operation is not implemented." message when creating the HTML project (however, I can create the desktop project and add the HTML client to it)



    Jay Turpin

    Thursday, May 16, 2013 12:46 PM
  • Thanks for the details Jay. I have tried a couple of additional repros and still have not been able to reproduce the issue. It is interesting that you can add an HTML Client to the SL client and have things work. At this point it might be useful to attach a debugger to the VS Instance that is reproing the problem to see if that can point us to something useful. Jay or Rob is that something that either of you would be willing to help out with? If you have already flattened the machines so that you could make progress I understand entirely.

    Thanks,

    Kris


    Kris Langohr | Senior SDET | LightSwitch QA

    Tuesday, May 21, 2013 4:52 PM
  • Kris - I would be happy to help out. My one machine still exhibits the issue. I'm happy to help collect some debug info, but I really don't have time to figure it out on my own. If someone from your team wants to get on the phone with me for 30 minutes to walk through the process, I'm happy to help.

    Thanks

    Jay Turpin

    Intel Corp


    Jay Turpin

    Wednesday, May 22, 2013 3:06 AM
  • Hi Kris,

    Thanks for the offer but as mentioned earlier in this thread, there are policies in place at my workplace which make remote debugging difficult. I suggest taking up Jay's offer initially at least.

    I am also able to add the HTML client to the SL application (requires an upgrade) - the HTML client does not show in solution explorer unless I close and reopen the project.

    Thanks for the investigation so far.

    Rob

    Wednesday, May 22, 2013 7:45 AM
  • Hi All,

    I have the same problem after upgrading with Update 2.

    I neither have "Upgrade Project" nor "Add Client"

    Thanks,

    Himanshu


    • Edited by Himanshu 7 Wednesday, May 29, 2013 9:29 PM
    Wednesday, May 29, 2013 9:29 PM
  • Hey Rob and Jay,

    Thanks to Jay I was able to spend some time taking a look at the issue that Jay was seeing. I was able to rule out the most common causes of similar type errors and I am continuing to investigate. I am following up with Jay offline with another mechanism to see if we can get some additional details that might point us in the right direction.

    Thanks,

    Kris


    Kris Langohr | Senior SDET | LightSwitch QA

    Wednesday, June 5, 2013 5:37 PM
  • Hi Kris and Jay,

    Thanks for following this up. I look forward to hearing the results of your investigation.

    Regards,

    Rob

    Thursday, June 6, 2013 10:14 AM
  • I am experiencing exactly the same issue. Has this been resolved?
    Wednesday, October 9, 2013 1:25 PM