none
Excel 2016 ActiveX working on local file; not from server share file RRS feed

  • Question

  • I have ActiveX references in my excel macro that work from a locally stored file, on my computer; but not working from my server share.  Macros are working both ways, ActiveX only locally.  I've tried relaxing the trust center to allow any ActiveX; set trusted locations to my server share; still not working.  They've been working for over 10years; recent office 365 updates seem to be causing this issue for me. (win7pro & win10pro).  Would really appreciate some  

    Robert

    Thursday, October 27, 2016 3:49 PM

All replies

  • I have some macro code with configured active x references.  We've been using the same code for 10 years.  Recently, I'm not sure what's changed, but these activex controls don't seem to load and cause my macros to fault (on 2 of my 10 machines).  I've tried the following steps to solving the issue.  I've adjusted trust center -macros enable all -trust access to vba project -activex enable all -trusted locations set to allow our network server and subfolders; basically, I've pulled my pants down and had no luck.  But!  If I copy the excel file from the network location, to my desktop (local drive), the activex loads and my macros work happily ever after.  What am I missing here?  Something is broken.
    We're running office 365 ProPlus 16.0.6001.1078.  one of the systems is Win7Pro; 2nd system is Win10Pro.


    Robert

    Wednesday, October 26, 2016 10:29 PM
  • Hi,

    This is the forum to discuss questions and feedback for Microsoft Excel, I'll move your question to the MSDN forum for Excel

    https://social.msdn.microsoft.com/Forums/en-US/home?forum=exceldev

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    Best Regards,
    Yuki Sun

    Thursday, October 27, 2016 3:14 AM
  • Hi,

    According to your description, recent update might cause the issue. What is your Office version now? Do you check the Trusted Documents setting in the Trust Center?

    Besides, what do you refer the control does not work? Meaning it could not show normally or the event would be triggered? 

    For the recently updating of Office, there are several known issues, please visit

    Fixes or workarounds for recent issues in Excel for Windows

    I would suggest you follow the link below to revert to an earlier version.

    https://support.microsoft.com/en-us/kb/2770432

    Regards,

    Celeste


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Saturday, October 29, 2016 11:22 AM
    Moderator