none
Cannot update WIN32 resources in assembly.. RRS feed

  • Question

  • Good morning,

    I´d like to ask you about this error: "Cannot update WIN32 resources in assembly "obj\Debug\aLibraryName.dll. The system cannot find the specified."

    I want to call VB.NET function written in Visual Studio 2013 from VBA Excel 2010 Workbook project.

    The error occours when I create Excel workbook add-in project based on my workbook with macros (*.xlsm) -> enable vba callers of ThisWorkBook class -> write some public method to the class -> hit debug -> the error occours and the assembly fails.

    System info: Windows 8.1 64-bit; MS Office 2010 32-bit; VS Pro 2013 (Visual Basic .NET).

    Thank you for response in advence. 

    Friday, November 29, 2013 8:14 AM

All replies

  • Hello frantisekjezek,

    Did you close all workbook designers before you start debugging? Also please check out the list of running processes for Excel.exe.

    Friday, November 29, 2013 11:15 AM
  • Yes Eugene,

    every workbook designers and excel processes were closed. The error still occoured. I tried the same steps (described on top) in VS Pro 2010 and there it was without any problems. This error occours with VS 2012 and 2013. However thank you for your reply. 

    Friday, November 29, 2013 11:38 AM
  • frantisekjezek,

    I have just noticed the following strange things:

    >> I want to call VB.NET function written in Visual Studio 2013

    Do you call a function in a VSTO based add-in or standalone app? Is it compiled as AnyCPU or x86 (see the target platform of your project)?

    >> System info: Windows 8.1 64-bit; MS Office 2010 32-bit; VS Pro 2013 (Visual Basic .NET).

    What configuration do you have set up on a PC with Visual Studio 2010 installed? Is there any x64?

    Friday, November 29, 2013 10:00 PM
  • It is VSTO based add-in (Excel Workbook add-in). The compile settings is set to AnyCPU. Both PCs have the same compile settings. Both PCs are x64 (I´ve tried it on PC with x86 and VS 2012 -> also the same problem).

    When I change compile settings from "AnyCPU" to "x86" -> no changes; when I change compile settings to "x64" the error changes to: "File "obj\Debug\aLibraryName.dll" is not a valid assembly.".

    Saturday, November 30, 2013 8:25 PM
  • Could you please describe the required steps for reproducing the issue? I will test it on PC.

    Saturday, November 30, 2013 10:28 PM
  • The steps are described here: http://msdn.microsoft.com/en-us/library/bb608609.aspx. It's described on MS Word Add-in, but it is the same process. When I followed the walkthrough (form MS Word) the same error occoured on the same place as in MS Excel Add-in: on the last step (3. Build the project.) of the paragraph 'Adding a Method to the ThisDocument Class'.

       
    Sunday, December 1, 2013 9:11 AM
  • Unfortunately I couldn't reproduce the issue on my PC (Win8 x64, Office 2013 x64, VS2013). May be someone from MSFT will try to reproduce the issue too.
    Sunday, December 1, 2013 10:16 PM
  • Ok, thank you very much for your effort Eugene. I'll try the help from MS. If you would like to, I can let you see the issue on my PC through Teamviewer. In this case let me know by mail (jezek@bexcellent.onmicrosoft.com).
    Monday, December 2, 2013 8:08 AM
  • Hi frantisekjezek,

    Unfortunately I am not a Microsoft employee and answer forum questions in my spare time :-/ Somebody from the VSTO team should take a look at the issue you faced with.

    Monday, December 2, 2013 9:47 AM
  • Finally I can answer this question since I ran into the same.
    After run VS2013 update posted on Jan 20, 2014, this problem is resolved.
    I strongly believe it WAS a bug and disappointed that no one pointed this out before. I wasted hours to google for solution.
    • Proposed as answer by Qijun Zhang Wednesday, January 22, 2014 12:00 PM
    Wednesday, January 22, 2014 12:00 PM
  • For some reason, after VSTO projects seemed to be working ok, I got this same error message ("cannot update win32 resources in assembly, the system could not find the file specified") repeatedly even with the simplest of VSTO VB.net Excel Workbook projects where I had EnableVbaCallers set to True.

    In case this helps, I eventually solved the problem by closing Visual Studio 2015 down and opening it up again!  

    VSTO in my experience is still very buggy, and it doesn't help that Microsoft's error messages are too often missing vital information (eg "the system could not find the file specified": why ON EARTH doesn't the error message say what the "file specified" is??).  For another example of VSTO being buggy, and useless error messages, see https://social.technet.microsoft.com/Forums/en-US/9e4b714e-bad4-4c62-a7ad-3c80e32d95eb/clickonce-fails-with-value-does-not-fall-within-the-expected-range.

    Saturday, October 17, 2015 5:58 PM