locked
Error: "Unable to connect to Visual Studio's Localhost Web Server" when running a local web project RRS feed

  • Question

  • User-2096557037 posted
    I get the above error when I try to run my project.  Any ideas what the configuration of the computer needs to be in order to run VS2005's local web server?
    Tuesday, July 26, 2005 9:55 AM

All replies

  • User-2096557037 posted
    Ok, the problem is that I apparently don't have the executable on my machine.  Does anyone know how I can reinstall this executable?  I've tried to repair my .NET studio installation, but no luck.
    Tuesday, July 26, 2005 11:09 AM
  • User-1863007166 posted
    I got same proplem , did you solve it ?

    if you .. please help me

    Thanks

    Friday, September 30, 2005 10:31 AM
  • User863284803 posted

    I accidentally hit my firewall program to block the web server application.  When I figured out that it had to be that - after hours - I permitted the application and worked fine.  Maybe try todisable the firewall and try to run it.

    Wednesday, October 19, 2005 4:34 PM
  • User-2049280417 posted

    hi,Echo88,

    the same problem happened to me,  and i solved it using the same method.

    appreciate your help.

    Tuesday, April 18, 2006 3:38 PM
  • User820538765 posted

    WebDev.WebServer.exe file is probably corrupted. Copy this file from another machine running vs2005 and replace the corrupt copy on your machine. Otherwise reinstall. WebDev.WebServer.exe can be found in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

    Tuesday, August 28, 2007 7:16 AM
  • User1577029266 posted

    ************************************************** Unable to connect to Visual Studio's Localhost Web Server ************************************************** Here is the solution below. Check it. ************************************************** The Visual Studio's localhost Web Server (or) Default Web Server is the file "WebDev.WebServer.exe". You can find it in the folder "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727" for Windows xp/2000/2003 (OR) in "C:\WINNT\Microsoft.NET\Framework\v2.0.50727" for Windows NT Servers.

    Check out whether this file exists in your framework folder to verify whether it was accidentally deleted. If it is not there, try to get a copy of this file from any another system which contains vs2005 installed and paste it the frameworks folder of your system.

    Keep a backup of this file "WebDev.WebServer.exe".

    Note: "WebDev.WebServer.exe" does not come with dotnet framework but with Visual Web Developer which is part of Visual Studio. Since it is in the framework's folder, dont' think that it came with dotnet framework file "dotnetfx20.exe".

    If not solved.
    Try to end any previous instances of WebDev.WebServer.exe still running using Task Manager.
    (or)
    Host your web application manually using WebDev.WebServer.exe. Type WebDev.WebServer.exe/? in Command Prompt (before doing this you to change the directory to framework folder or add the framework folder to PATH in console.
    The syntax is : WebDev.WebServer.EXE /path:$rpath /port:$port /vpath:$vpath
    Where path is for physical path location of your application's root directory, port is the port number your application uses, you can assign any free or unused port number and vpath is the virtual directory name for your application's root directory
    Example: WebDev.WebServer.exe /path:f:\myprojects\webapps\website1 /port:1036 /vpath:website1 (physical path and virtual path need not be same as in this case 'website1')
    Now you will see the icon in the tray which you usually see when you run a webapplication from visual studio ide.
    and now you can accesss your application from any browser by simply typing for the above example as
    http://localhost:1036/website1
    Note: Here instead of localhost you can use your computer fullname.
    (or)
    Try this: In the frame work folder 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727' Run the following files..
    'aspnet_regiis -i' : to register asp.net with Internet Information Server (IIS) and
    'iisreset' : to restart IIS

    If the problem still exists try to call me om my mobile.

    Regards,
    Sriram Naresh

    Friday, October 26, 2007 6:07 PM
  • User1577029266 posted

    The Visual Studio's localhost Web Server (or) Default Web Server is the file "WebDev.WebServer.exe". You can find it in the folder "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727" for Windows xp/2000/2003 (OR) in "C:\WINNT\Microsoft.NET\Framework\v2.0.50727" for Windows NT Servers.

    Check out whether this file exists in your framework folder to verify whether it was accidentally deleted. If it is not there, try to get a copy of this file from any another system which contains vs2005 installed and paste it the frameworks folder of your system.

    Keep a backup of this file "WebDev.WebServer.exe".

    Note: "WebDev.WebServer.exe" does not come with dotnet framework but with Visual Web Developer which is part of Visual Studio. Since it is in the framework's folder, dont' think that it came with dotnet framework file "dotnetfx20.exe".

    If not solved.
    Try to end any previous instances of WebDev.WebServer.exe still running using Task Manager.
    (or)
    Host your web application manually using WebDev.WebServer.exe. Type WebDev.WebServer.exe/? in Command Prompt (before doing this you to change the directory to framework folder or add the framework folder to PATH in console.
    The syntax is : WebDev.WebServer.EXE /path:$rpath /port:$port /vpath:$vpath
    Where path is for physical path location of your application's root directory, port is the port number your application uses, you can assign any free or unused port number and vpath is the virtual directory name for your application's root directory
    Example: WebDev.WebServer.exe /path:f:\myprojects\webapps\website1 /port:1036 /vpath:website1 (physical path and virtual path need not be same as in this case 'website1')
    Now you will see the icon in the tray which you usually see when you run a webapplication from visual studio ide.
    and now you can accesss your application from any browser by simply typing for the above example as
    http://localhost:1036/website1
    Note: Here instead of localhost you can use your computer fullname.
    (or)
    Try this: In the frame work folder 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727' Run the following files..
    'aspnet_regiis -i' : to register asp.net with Internet Information Server (IIS) and
    'iisreset' : to restart IIS

    Regards,
    Sriram Naresh

    Tuesday, April 8, 2008 12:12 AM
  • User1577029266 posted

    The Visual Studio's localhost Web Server (or) Default Web Server is the file "WebDev.WebServer.exe". You can find it in the folder "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727" for Windows xp/2000/2003 (OR) in "C:\WINNT\Microsoft.NET\Framework\v2.0.50727" for Windows NT Servers.

    Check out whether this file exists in your framework folder to verify whether it was accidentally deleted. If it is not there, try to get a copy of this file from any another system which contains vs2005 installed and paste it the frameworks folder of your system.

    Keep a backup of this file "WebDev.WebServer.exe".

    Note: "WebDev.WebServer.exe" does not come with dotnet framework but with Visual Web Developer which is part of Visual Studio. Since it is in the framework's folder, dont' think that it came with dotnet framework file "dotnetfx20.exe".

    If not solved.
    Try to end any previous instances of WebDev.WebServer.exe still running using Task Manager.
    (or)
    Host your web application manually using WebDev.WebServer.exe. Type WebDev.WebServer.exe/? in Command Prompt (before doing this you to change the directory to framework folder or add the framework folder to PATH in console.
    The syntax is : WebDev.WebServer.EXE /path:$rpath /port:$port /vpath:$vpath
    Where path is for physical path location of your application's root directory, port is the port number your application uses, you can assign any free or unused port number and vpath is the virtual directory name for your application's root directory
    Example: WebDev.WebServer.exe /path:f:\myprojects\webapps\website1 /port:1036 /vpath:website1 (physical path and virtual path need not be same as in this case 'website1')
    Now you will see the icon in the tray which you usually see when you run a webapplication from visual studio ide.
    and now you can accesss your application from any browser by simply typing for the above example as
    http://localhost:1036/website1
    Note: Here instead of localhost you can use your computer fullname.
    (or)
    Try this: In the frame work folder 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727' Run the following files..
    'aspnet_regiis -i' : to register asp.net with Internet Information Server (IIS) and
    'iisreset' : to restart IIS

    If the problem still exists try to call me om my mobile.

    Regards,
    Sriram Naresh

    Tuesday, April 8, 2008 12:16 AM
  • User820538765 posted

    Dude I gave a short and concise answer and you had to repeat it three times ??

    anyway thanks for the greater detail 

    Wednesday, May 28, 2008 9:55 AM
  • User-1807309021 posted

     The basic requirment for VS2005 is minimum of 256mb Ram and above 2 GB Hard disk space, The CPU speed above 1.7 Ghz

    Shane 

    Monday, June 2, 2008 7:34 AM
  • User1623073886 posted

    sorry guys, maybe an old story, but i just had the same problem and loked around.

    I am running Visual studio 2008 professional and tried Microsoft Visual Web Developer 2008 Express Edition - just for fun and evaluation - then suddently my VS2008 stopped connecting to localhost developer web server when testing my projects. After a vhile i was lucky to solve it in 5 minutes - maybe som one could use my experience.

    - when testing a webapplication i tried to substitute localhost with 127.0.0.1 - then things worked again 
    - 'ping localhost' showed me that localhost did not longer point to loopback adress 127.0.0.1 - don't know why
    - edited the file 'hosts' in \%systemrpoot%\system32\drivers\etc\ (i don't have my own DNS server so i do static hostmappings)
    - corrected the corrupt localhost entry to: 127.0.0.1 localhost

    thats all - works fine again, no need for reinstalling and so on
    hope u can use it - /Kim Steffensen

      

     

       

    Tuesday, March 10, 2009 4:47 PM
  • User2039994315 posted
    THNX! It helped.
    Tuesday, March 10, 2009 6:30 PM
  • User-2058570687 posted

    <style type="text/css"> @page { margin: 0.79in } P { margin-bottom: 0.08in } --> </style>

    Commented out the line

    ::1 LocalHost

    with a # in the hosts file and it now works.

    or

    remove the next line in the windows host file C:\Windows\System32\drivers\etc\hosts

    ::1 localhost

    This is an IpV6 entry. Put a # in front of it. "

    Instead of commenting this IpV6 entry adding the following IpV4 entry above this line also helps:

    127.0.0.1 localhost

    Thursday, March 12, 2009 7:48 AM
  • User-539551168 posted

    The plot thickens..seem you can no longer edit this file ...

     I think following information might be useful to you. Windows Vista does not let you mess with the hosts file located at C:\Windows\System32\drivers\etc\

    (even if you are logged in as an administrator).

    There is a simple workaround for it.

    Follow these steps:-

    1. Click on Start Button
    2. Rt. click on 'Notepad'
    3. Click "Run As Administrator"
    4. Click "Continue" on the prompt
    5. Navigate to C:\Windows\System32\drivers\etc\ using Notepad's 'Open' location option.
    6. Select 'all files' and then choose the 'hosts' file. Make necessary changes and save!

    THANKS that fixed it ..

    btw ..the script editor for IE8....developer tools looks good but dosen't let you ..edit java script!  So this is why you must use visual web developer 2008 Express Edition - let you get around this - go File ->new web site -> empty web site. Replace it with your html. You should be able to get a script editor go in vista that lets you edit Javascript.

     

    Q.does anyone know why they stopped this .. editing of the hosts file .. should i change it back if i'm online? ?

     

    thx mike

    Tuesday, October 6, 2009 7:55 AM
  • User-143438668 posted

     Check the Below Link. I bet  you will get a solution :

    http://softwares-u-need.blogspot.com/search/label/asp.net


    I faced the same problem long days before, so made this post on that blog.

    " Unable to connect to Visual Studio's Localhost Web Server SOLVED/FIXED "


    Thursday, September 9, 2010 11:43 AM
  • User-801004448 posted

    Q.does anyone know why they stopped this .. editing of the hosts file .. should i change it back if i'm online? ?

    To prevent people messing their  own network connection?

    There's no need to change when you go online. localhost should point 127.0.0.1 by default.

    Sunday, September 12, 2010 9:49 PM
  • User976579494 posted

    Hello Vibin

    there is a file called WebDev.WebServer.exe which was located in C:\WINNT\Microsoft.NET\Framework\v2.0.50727
    so copy WebDev.WebServer.exe file from other working system and just replace it.
    This Works me fine


    Monday, October 25, 2010 2:54 AM
  • User-143438668 posted

    I am Glad. it help you...

    Friday, November 5, 2010 8:13 AM
  • User1784871874 posted

    Thanks you :)

    this resolves my problem........

    Wednesday, March 1, 2017 4:38 AM