locked
500 - The request timed out RRS feed

  • Question

  • User572431586 posted

    Hi,

    I have a long running api request (about 30-40 mins). But after a short while I get HTTP 500 (The request timed out).

    In the web.config I have:

        <httpRuntime targetFramework="4.5" maxRequestLength="204800" executionTimeout="99999" requestValidationMode="2.0" />

    But the timeout seems still to be at the default value at 90 seconds? Is there any more setting I can do?

    It's no problem when running the request on localhost but gets the timeout when published. The web app is hosted in Azure.

    Friday, April 22, 2016 10:26 AM

Answers

  • User-1315512054 posted

    Hello,

    You will need bigger application pool timeout. It seems that you use Azure in Shared mode, and you should Reserved instance, so your site be always in memory.

    Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 22, 2016 5:04 PM
  • User-166373564 posted

    Hi Asus,

    But the timeout seems still to be at the default value at 90 seconds? Is there any more setting I can do?

    For the executionTimeout option, this time-out applies only if the debug attribute in the compilation  element is False. Therefore, if the debug  attribute is True, you do not have to set this attribute to a large value in order to avoid application shutdown while you are debugging.

    The default is 110 seconds.

    Please check whether it helps.

    Have a good day.

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, April 23, 2016 2:58 AM

All replies

  • User-1315512054 posted

    Hello,

    You will need bigger application pool timeout. It seems that you use Azure in Shared mode, and you should Reserved instance, so your site be always in memory.

    Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 22, 2016 5:04 PM
  • User-166373564 posted

    Hi Asus,

    But the timeout seems still to be at the default value at 90 seconds? Is there any more setting I can do?

    For the executionTimeout option, this time-out applies only if the debug attribute in the compilation  element is False. Therefore, if the debug  attribute is True, you do not have to set this attribute to a large value in order to avoid application shutdown while you are debugging.

    The default is 110 seconds.

    Please check whether it helps.

    Have a good day.

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, April 23, 2016 2:58 AM