locked
My Homemade web browser cannot debug on my other computers RRS feed

  • Question

  • Hey:

    Recently, my friends and i made a web browser based on chrome and gecko. We had Visual Studio 2010 and devexpress 10.5 version

    When i debug (F5) on the computer that i use to make the project, it runs perfectlly fine. So i put ALL the files on my USB and run it on my other computer which is also Vista 64bits. When i click on the .exe icon. It says EthupBolt (Which is my program's name) Is not responding. Then i have to close it.

    I CANT RUN MY WEB BROWSER ON OTHER COMPUTERS EXCEPT FOR THE COMPUTERS THAT MY FRIENDS AND I USED IT TO MAKE the web browser.

     

    I'm pretty sure i included all the files in the dubug file. So pleaes help!! this web browser is much better than firefox... no offense, I have to publish it this November.

     

    Thanks!!!

    Saturday, June 18, 2011 8:39 PM

Answers

All replies

  • You may capture a dump file for the hang applicaiton, and then do some investigation on the dump file.

    See also: How to use ADPlus to troubleshoot "hangs" and "crashes"


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Rich Wang Wednesday, June 29, 2011 12:41 AM
    Monday, June 20, 2011 3:01 AM
  • Okay, that i will look in to it. What if i make my web browser as intallation file. I mean people who download it is not portable, they have to install it to their computer. Would that work?
    Monday, June 20, 2011 8:21 PM
  • You may capture a dump file for the hang applicaiton, and then do some investigation on the dump file.

    See also: How to use ADPlus to troubleshoot "hangs" and "crashes"


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Okay, so I see that  ADPlus makes my debugger more reliable. So I just need to install it and that is all?  (PS I have about 5 Try statements  in my codes. I recently changed the dubug mode into All Platform. Does it mean that all PC can use the program? Or just 64 and 32bits?

    Thank You

    • Marked as answer by Rich Wang Wednesday, June 29, 2011 12:41 AM
    • Unmarked as answer by Rich Wang Wednesday, June 29, 2011 12:41 AM
    Monday, June 20, 2011 8:27 PM
  • All Platform? Do you mean "Any CPU"? An "Any CPU" application can run as 32bit process on 32bit Windows, or as 64bit process on 64bit Windows;

     

    It is a good idea to make a installation package for your application, if it is .NET application, the target machine need to install corresponding .NET Framework, you can make it as pre-requirement, see Application Deployment Prerequisites


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, June 21, 2011 2:39 AM
  • Currently, i'm debugging as NET FRAMEWORK 4.0. Most of the computers i encountered have 3.0. So when i dubug it as 3.0, it gave me several errors that i cant solve.

    I will try ADPlus later.

     

    Tuesday, June 21, 2011 4:02 PM
  • All Platform? Do you mean "Any CPU"? An "Any CPU" application can run as 32bit process on 32bit Windows, or as 64bit process on 64bit Windows;

     

    It is a good idea to make a installation package for your application, if it is .NET application, the target machine need to install corresponding .NET Framework, you can make it as pre-requirement, see Application Deployment Prerequisites


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    I tired Any CPU (all platform) about 2months ago. It shows me the same problem that Ethup Bolt is not responding and user have to close the program. Will the same problem appear again if i make it as intallation?
    Tuesday, June 21, 2011 4:05 PM