locked
Set build service as Interactive, need manage build resources perms RRS feed

  • Question

  • I am trying to integrate Test Complete into TFS 2010 on Server 2008 R2 SP1

    I go into TFS Admin Console/Build Configuration

    Click on properties

    click on "stop to make changes"

    Select the Interactive Process radio button

    Click Start

    I get the following popup error

    Cannot register Team Foundation Build Service: Failed to create BuildServiceHost object. User DEVSERVER01\tonyedmo needs the 'ManageBuildResources' permission.

    Funny thing is in the event logs for the error it says same thing except it say DEVSERVER01\TfsBuildUser, which is the user I use for the service.

    Both tonyedmo and TfsBuildUser have the ManageBuildResources perm

    here is the event log entry

    Service 'DEVSERVER01 - Agent1' had an exception: 
    Exception Message: TF277005: Access denied. DEVSERVER01\TFSBuildUser needs the Manage build resources privilege to perform this action. For more information, contact the Team Foundation Server administrator. (type AccessDeniedException)

    Exception Stack Trace:    at Microsoft.TeamFoundation.Client.TeamFoundationClientProxyBase.ProcessHttpResponse(HttpWebResponse response, Stream responseStream, WebException webException, XmlReader& xmlResponseReader)
       at Microsoft.TeamFoundation.Client.TeamFoundationClientProxyBase.ExecWebServiceRequest(HttpWebRequest request, XmlWriter requestXml, String methodName, HttpWebResponse& response)
       at Microsoft.TeamFoundation.Build.Client.AdministrationWebService.UpdateBuildAgents(BuildAgentUpdateOptions[] updates)
       at Microsoft.TeamFoundation.Build.Client.BuildServer.SaveBuildAgents(IBuildAgent[] agents)
       at Microsoft.TeamFoundation.Build.Machine.BuildAgentService.<>c__DisplayClass12.<TestConnection>b__11(Object )

    Inner Exception Details:

    Exception Message: TF277005: Access denied. DEVSERVER01\TFSBuildUser needs the Manage build resources privilege to perform this action. For more information, contact the Team Foundation Server administrator. (type SoapException)
    Exception Stack Trace: 

    Extra Notes that may be important:

    This build server has been working for awhile now, I and just trying to add more to it.

    This build server is not part of any domain

    Let me know if I can provide more info, and thanks for any help you can provide.


    • Edited by Wieknot Monday, April 9, 2012 12:04 PM
    Monday, April 9, 2012 11:43 AM

All replies

  • I know maybe my answer will not be very good for you, but try to see the TFS installation guide videos, it will show you exactly what permission you will need to assign to any service accounts you will use,  because to answer your question I may need asking many questions to know exactly what you have, so I can give you the exactly answer.


    We are volunteers, if the reply help you mark it as your answer. thanks!!

    Blog: http://mohamedradwan.wordpress.com

     

    Monday, April 9, 2012 9:12 PM
  • Hi Tonyedmo, 

    Thanks for your post. 

    Which credential you provided in Build Service Properties window as the Build Service account, the user DEVSERVER01\tonyedmo? If yes, please check this user’s permission in your Team Project Collection, the Build Service account usually add in [CollectionName]\Project Collection Build Service Account group. Please check the permissions of this user DEVSERVER01\tonyedmo in Team Project Collection level, ensure it has the Manage build resource permission.   


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, April 10, 2012 2:17 AM
    Moderator
  • As I said in my question.

    TfsBuildUser is what the service uses and that TfsBuildUser and tonyedmo both have Manage Build Resources permission. In fact both now have all available collection permissions :-)

    Tuesday, April 10, 2012 11:05 AM
  • Hi Tonyedmo, 

    Thanks for your reply.

    I suggest you upgrade your TFS 2010 and VS 2010 both to TFS 2010 SP1 and VS 2010 SP1. 

    Could you try to remove that Agent1 and New an agent, then try again? 

    This issue requires more troubleshooting and I can’t reproduce this scenario on my machine. If it is urgent issue, I suggest you to contact a Professional Support Service at http://support.microsoft.com/common/international.aspx?RDPATH=gp;en-us;offerprophone to gain more support on this case.  

     


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, April 11, 2012 2:53 AM
    Moderator
  • VS2010 sp1 was installed already

    I install TFS 2010 sp1 but still get same error


    Thursday, April 12, 2012 9:37 PM
  • Hi Tonyedmo, 

    Thanks for your reply.

    Have you tried to remove that Agent1 and create a new agent and restart your Build Service?   


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us

    Friday, April 13, 2012 2:38 AM
    Moderator
  • Will try this weekend in case it kills our build server, so I will have time to fix it.
    Friday, April 13, 2012 12:05 PM
  • If I log in as the actual admistrator user, I am able to delete and recreate the service, Controller and agent.  I am also able to start the service service in interactive mode.

    A console like windows pops up and says: Team Foundation Build Service is running in interactive mode. If you are finished using the Build Service, Press the Escape key <Esc> to exit ...

    And then shows the same error listed in original question.

    It looks like it is still running in interactive mode, Im going to try and add Test Complete to a build , and see what happens.


    Monday, April 16, 2012 1:33 PM