locked
Arrange controls in one column without indent RRS feed

  • Question

  • Hello.

    I have a problem to arrange the LS controls in one column when I use Group Layout item, they are always indented. Picture below.

    I have tried all the options left, right size..... and nothing happens.

    Creation of custom control is not an option.

    Thank you in advance.

    

    Tuesday, November 4, 2014 12:31 PM

All replies

  • Hi!

    I didn't find a way to do that out of the box (group layout control does not support label), but if you are willing to install 3d party Pixata controls from mr. Yossu (Alan Silver), you'll find that he managed to do group layout control with label.. after that you can play and get wanted results (like put label on group control and remove label from first column, or something simlar).. downside is that you cannot control font (if field is required it won't be bold, etc.).. also you'll find some other nice stuff in his package.. hth and "sretno"..

    Kivito


    Nobody expects the Spanish Inquisition! (M.P.F.C.)


    • Edited by Kivito Tuesday, November 4, 2014 1:34 PM
    Tuesday, November 4, 2014 1:32 PM
  • Thank you for the fast answer but I can't do that, company policy. I need an answer how to do that without custom controls or any other free controls.

    Sava.

    Wednesday, November 5, 2014 12:08 PM
  • One way would be to put the titles of the fields at the top.

    The second option would be to delete the group box in the middle.

    In the latter case you can create three items Layout groups and divide the fields by placing the group box in the Middle group item.

    Wednesday, November 5, 2014 1:57 PM
  • Thanks for the answer.

    First option is not ok because the users need for titles to be put beside input fields.

    Second option. I just put a group box for an example, what if I have few group boxes and layout items?That is where it gets comlicated.

    Can you put a screenschoot or give more explanations? If you thought that I put all the fields in layout items I tried that but every time when I have some layout items in some layout items I have the same problem.


    Friday, November 7, 2014 10:27 AM
  • hi!

    check this link: http://blogs.msdn.com/b/lightswitch/archive/2011/06/23/tips-and-tricks-for-using-the-screen-designer.aspx , maybe you'll find something useful there considering your problem, perhaps table control? hth..

    Kivito


    Nobody expects the Spanish Inquisition! (M.P.F.C.)

    Friday, November 7, 2014 11:27 AM
  • Select Group Box in design. Change label position for collapsed in properties.

    Don't forget to change the position of the text to left-aligned fields within the group box.

    Saturday, November 8, 2014 9:31 PM
  • Thank you for the answer but that doesn't solve the problem completely. As you can see in the picture below group is better sorted but again it is not in a correct way. If you have any ideas hot to solve this it would be great.

    Friday, November 28, 2014 11:46 AM
  • Move the fields out of the group. Define 20px in size the height of the group.
    Saturday, August 8, 2015 8:43 PM