none
.net Framework RRS feed

  • Question

  • I have .NET Framework 3.5 SP1 and .NET Framework 4 Client Profile with updates.  Can I delete previous versions (2.0 service pack 2 and 3.0 service pack 2)?
    Thursday, May 17, 2012 2:14 PM

Answers

  • No!

    .NET Framework 3.5 is an EXTENSION of .NET 2.0, NOT a full framework.

    .NET 2.0, 3.0 and 3.5 are all ONE framework, and must be installed together.

    The programs you use require specific .NET Framework versions, so even though .NET Framework 4.0 Client Profile is a separate framework, programs written to require .NET Framework 3.5 will not work with just 4.0 installed.

    My advice: leave the installed .NET Frameworks alone.

    Thursday, May 17, 2012 3:26 PM