locked
Table Storage API InvalidURI RRS feed

  • Question

  • When I browse to 

    [myaccountname].table.core.windows.net/

     (as copied from my Storage Dashboard), I get this result:

    <error xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">
    <code>InvalidUri</code>
    <message xml:lang="en-US">
    The requested URI does not represent any resource on the server. RequestId:9479c451-9163-43d1-a6df-d305a0d98c72 Time:2013-09-25T01:45:32.1373412Z
    </message>

    </error>

    Specifically I want to query my MetricsCapacityBlob table as follows:  

    [myaccountname].table.core.windows.net/Tables("$MetricsCapacityBlob") 

    , but I get this :

    <error xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">
    <code>ResourceNotFound</code>
    <message xml:lang="en-US">
    The specified resource does not exist. RequestId:b40b27b8-ced5-4743-99bb-0316919c7b73 Time:2013-09-25T01:52:57.9488064Z
    </message>

    </error>

    Please help.

    Wednesday, September 25, 2013 1:54 AM

Answers

  • 2 things are happening here:

    1. You can't directly browse your table storage like this by typing the table storage endpoint in browser window. All requests to table storage must be authenticated. What that means is that you will have to write some code to access tables in your storage account. You could either consume the REST API or use storage client library to access your storage.
    2. Coming to accessing "$MetricsCapacityBlob" table, please note that this table is a special table (as it is part of storage analytics) and is only created in your storage account if you enable storage analytics on your storage account. If the analytics is not enabled, you would need to do that first. You could make use of this free tool to enable storage analytics on your storage account: http://blog.cerebrata.com/articles/2011/08/11/cerebrata-windows-azure-storage-analytics-configuration-utility-a-free-utility-to-configure-windows-azure-storage-analytics/. Once the analytics is enabled, you may want to wait for some time to get this table populated.

    Hope this helps.

    Wednesday, September 25, 2013 2:37 AM