locked
SQLBROWSER runs, but 'netstat -ano' doesnt show UDP 1434 (how to troubleshoot) RRS feed

  • Question

  • i have been running sqlexpress2005 sp3 successfully (installed as a named instance) to a stand alone computer.

    i just noticed today that when i run...

      netstat -ano | findstr 1434

    nothing is listed!!!  if i go to services.msc and stop and restart sqlbrowser, it says its able to be controlled, and stopped, and started.

    i would like to know how to troubleshoot this...

    is there a way to know for sure if sqlbrowser is actually binding to UPD port 1434?

    or is there some problem on my system that prevents this port from showing up in netstat.  here is what netstat -ano reveals...

    C:\Program Files\Support Tools>netstat -ano

    Active Connections

      Proto  Local Address          Foreign Address        State           PID
      TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       1208
      TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
      TCP    0.0.0.0:2101           0.0.0.0:0              LISTENING       516
      TCP    0.0.0.0:2967           0.0.0.0:0              LISTENING       1932
      TCP    0.0.0.0:3260           0.0.0.0:0              LISTENING       180
      TCP    0.0.0.0:3261           0.0.0.0:0              LISTENING       180
      TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       1160
      TCP    127.0.0.1:1096         127.0.0.1:27015        ESTABLISHED     2376
      TCP    127.0.0.1:1097         0.0.0.0:0              LISTENING       3580
      TCP    127.0.0.1:1113         0.0.0.0:0              LISTENING       2144
      TCP    127.0.0.1:5354         0.0.0.0:0              LISTENING       256
      TCP    127.0.0.1:27015        0.0.0.0:0              LISTENING       2032
      TCP    127.0.0.1:27015        127.0.0.1:1096         ESTABLISHED     2032
      TCP    192.168.0.164:139      0.0.0.0:0              LISTENING       4
      TCP    192.168.0.164:1323     168.75.225.41:11438    ESTABLISHED     2196
      TCP    192.168.0.164:1940     192.168.0.80:3389      ESTABLISHED     3988
      TCP    192.168.0.164:2004     70.168.50.45:21        ESTABLISHED     608
      TCP    192.168.0.164:2522     192.168.0.165:139      ESTABLISHED     4
      TCP    192.168.0.164:2647     168.75.225.44:80       TIME_WAIT       0
      TCP    192.168.0.164:2648     168.75.225.44:80       ESTABLISHED     2196
      TCP    192.168.0.164:2649     168.75.225.44:80       ESTABLISHED     2196
      UDP    0.0.0.0:445            *:*                                    4
      UDP    0.0.0.0:500            *:*                                    984
      UDP    0.0.0.0:1038           *:*                                    256
      UDP    0.0.0.0:1941           *:*                                    3988
      UDP    0.0.0.0:4112           *:*                                    1932
      UDP    0.0.0.0:4500           *:*                                    984
      UDP    0.0.0.0:64908          *:*                                    256
      UDP    127.0.0.1:123          *:*                                    1276
      UDP    127.0.0.1:1025         *:*                                    984
      UDP    127.0.0.1:1060         *:*                                    560
      UDP    127.0.0.1:1082         *:*                                    928
      UDP    127.0.0.1:1900         *:*                                    1380
      UDP    127.0.0.1:2041         *:*                                    3656
      UDP    127.0.0.1:2048         *:*                                    3732
      UDP    127.0.0.1:2384         *:*                                    3108
      UDP    127.0.0.1:4715         *:*                                    2196
      UDP    192.168.0.164:123      *:*                                    1276
      UDP    192.168.0.164:137      *:*                                    4
      UDP    192.168.0.164:138      *:*                                    4
      UDP    192.168.0.164:1900     *:*                                    1380
      UDP    192.168.0.164:5353     *:*                                    256
      UDP    192.168.0.164:17234    *:*                                    2196
      UDP    192.168.0.164:17708    *:*                                    2196
      UDP    192.168.0.164:26922    *:*                                    2196
      UDP    192.168.0.164:32301    *:*                                    2196

    note here TCP 2101 is the port that sqlexpress (named instance) is listening on, so thats fine.

    im just stumped as to why sqlbrowser's UDP 1434 isnt showing in this list.

    help would be gratefully appreciated.

    greg

     

    Friday, March 26, 2010 7:52 PM

All replies

  • Hi greg aiken,

    First, please download "TCPView" to see whether port of 1434 is shown.
    Assuming that you could see the port of 1434, if the port’s owner isn’t SQL Server Browser, end this process and start SQL Server Browser, if it is, I recommend that you go to windows server to ask what’s wrong.

    If you can't, please stop "SQL Server Browser" service and execute "sqlbrowser -c" in C:\Program Files\Microsoft SQL Server\90\Shared folder for troubleshooting.
    Or you can view system's application log to see what's wrong via running "eventvwr.msc" in windows run dialog.

    Download
    "TCPView": http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx

    For more information:
    "SQL Server Browser Service": http://msdn.microsoft.com/en-us/library/ms181087.aspx

    Regards,
    Tom Li - MSFT
    • Proposed as answer by Tom Li - MSFT Monday, April 5, 2010 1:32 AM
    • Unproposed as answer by Tom Li - MSFT Thursday, September 23, 2010 1:28 AM
    Tuesday, March 30, 2010 6:07 AM
  • thanks tom.

    sorry for delay here.  today i installed 'tcpview', ran it and it showed the same basic info as netstat.  there was no entry in column 1 for 'sqlbrowser' (application column).  and there was no entry in port # column for UDP port 1434

    i feel i will need to dig deeper.  you suggested i ask a question in 'server' category.  do you have the direct url for the suggested page?

    again thanks for your assistance.

    greg

    Wednesday, April 7, 2010 11:21 PM
  • Can you start the browser from the command prompt and share the messages that follow?

     

    Wednesday, September 15, 2010 11:59 PM
    Answerer
  • Neither netstat or tcpviewer shows information about UDP.

     


    Kristian
    Thursday, September 16, 2010 11:19 AM
  • Can you start the browser from the command prompt and share the messages that follow?
    Friday, September 17, 2010 12:29 PM
    Answerer
  • dear vijay,

    thanks so m uch for your interest here to help me.  alot of time has passed here with no resolve or any direction to solution.

    heres what i tried, based on your suggestion.

    1. confirmed in services.msc, that sqlbrowser was in fact running.  it was.

    2. netstat -ano  and confirmed once again that nothing was binding to port 1434

    3. i went back to services.msc, i brought up property sheet of that service entry, i 'stop'.  sqlbrowser stopped.

    4. with sqlbrowser stopped - i theorized possibly two programs might both be trying to claim port 1434 UDP - so with sqlbrowser stopped, i again ran netstat -ano to see if magically UPD 1434 might show, with another application binding to it.  sadly, UDP 1434 still does not list.

    5. property sheet of sqlbrowser (in services.msc) indicated field value for 'path to executable' = c:\program files\microsoft sql server\90\shared\sqlbrowser.exe, and 'start parameters' = null.  i inferred from this that all required to start this from a command line would be to invoke 'cmd.exe', cd into that folder, then execute 'sqlbrowser.exe'.  i did this.  there was NO response from the os.

    what (i feel anyways) is weird here is that i then went to services.msc and as far as services.msc is concerned, it did not show sqlbrowser as beng started.  well since i didnt start it from services.msc - perhaps thats not too weird. 

    but what was definitely weird was that i then started taskmgr.exe and in 'processes' tab, 'sqlbrowser' was NOT listed!  (note when sqlbrowser was started using services.msc, taskmgr.exe DOES show 'sqlbrowser' running in the processes tab.

    i then went to a totally different computer that also runs sql2005 as a named instance, and that also has sqlbrowser installed and where both programs seem to be controllable via services.msc.  i was able to repeat what is written here in the previous three paragraphs on a TOTALLY DIFFERENT COMPUTER.

    i am at a total loss as to why when sqlbrowser is started from services.msc, that it lists in taskmgr.  yet when started from cmd line, it does not list in takmgr - unless there is some innate flaw in trying to start it from a command line, and in fact it is not able to be started from the command line.

    if it matters, on both computers, sqlbrowser, in services.msc, the property sheet has this service running as the 'Local System Account'.

    anyways that is all that i can add here...

    might you have any more troubleshooting suggestions?

    sincerely,

    greg

    Wednesday, September 22, 2010 4:50 PM
  • Apologize Greg. I should have made it clear

    Try -

    sqlbrowser.exe -c

    http://msdn.microsoft.com/en-us/library/ms181087.aspx

     

    Thursday, September 23, 2010 4:56 AM
    Answerer
  • vishay,

    A.  on a properly working computer where sqlbrowser behaves 'normally', i stopped sqlbrowser from 'services.msc' \ 'sqlbrowser' property sheet.  i then opened cmd window and moved into '...90\shared' folder, and ran 'sqlbrowser.exe -c'.  i waited some 20 seconds, then eventually hit 'control-c' to stop this process.  the screencap resulting (on a 'normal' pc follows):

    C:\Program Files\Microsoft SQL Server\90\Shared>sqlbrowser.exe -c
    SQLBrowser: starting up in console mode
    SQLBrowser: starting up SSRP redirection service
    SQLBrowser is successfully listening on ::[1434]
    SQLBrowser is successfully listening on 0.0.0.0[1434]
    [2900]: Waiting for next request...
    [2900]: Received request...
    [3944]: Waiting for next request...
    [3944]: Received request...
    [3944]: Waiting for next request...
    [3944]: Received request...
    [4396]: Waiting for next request...
    [1296]: Waiting for next request...
    [2900]: Waiting for next request...
    [3944]: Waiting for next request...
    [4396]: Received request...
    [4396]: Waiting for next request...
    SQLBrowser: CTRL-C received. Shutting down browser service

    ps - on this properly working computer, with sqlbrowser running, 'netstat -ano' DOES list UDP port 1434 as being bound by some application.

    B. on MY computer, where sqlbrowser is NOT behaving normally, i did exact same thing.  Here is the screencap from MY computer:

    C:\Program Files\Microsoft SQL Server\90\Shared>sqlbrowser.exe -c
    SQLBrowser: starting up in console mode
    SQLBrowser: CTRL-C received. Shutting down browser service

    Friday, September 24, 2010 4:13 PM