none
Plotting a route between two addresses RRS feed

  • Question

  • So I am fairly new to the c# side of things as well as to the Windows Store App side as well.

    Here is what I am trying to do.

    I want to be able to add a From:(address) and a To:(address) than click a button to plot that route.

    The issue that I come across in all of the examples is that everyone is just using a Point as a reference. Ex. Seattle to New York.

    I have looked at this example many of times http://rbrundritt.wordpress.com/2012/12/12/geocoding-and-routing-in-bing-maps-windows-store-apps-native/#comment-2638 and still can't figure out how to put addresses into the textboxes so that they return the route.

    Example:

    From: 11010 NE 8th St, Bellevue, WA, United States    

    To: 3181 156th Ave SE, Bellevue, WA, United States

    Monday, June 10, 2013 10:48 PM

Answers

  • Addresses do work with that code as is. This code sample should be generating a REST url similar to this: http://dev.virtualearth.net/REST/V1/Routes/Driving?wp.0=11010%20NE%208th%20St,%20Bellevue,%20WA,%20United%20States%20&wp.1=3181%20156th%20Ave%20SE,%20Bellevue,%20WA,%20United%20States&rpo=Points&key=YOUR_BING_MAPS_KEY

    Modifying this URL with your Bing Maps key and you will see that it finds your route without any issues.


    http://rbrundritt.wordpress.com

    • Proposed as answer by Ricky_Brundritt Tuesday, June 11, 2013 10:53 AM
    • Marked as answer by Texeco Tuesday, June 11, 2013 4:41 PM
    Tuesday, June 11, 2013 10:53 AM

All replies

  • Addresses do work with that code as is. This code sample should be generating a REST url similar to this: http://dev.virtualearth.net/REST/V1/Routes/Driving?wp.0=11010%20NE%208th%20St,%20Bellevue,%20WA,%20United%20States%20&wp.1=3181%20156th%20Ave%20SE,%20Bellevue,%20WA,%20United%20States&rpo=Points&key=YOUR_BING_MAPS_KEY

    Modifying this URL with your Bing Maps key and you will see that it finds your route without any issues.


    http://rbrundritt.wordpress.com

    • Proposed as answer by Ricky_Brundritt Tuesday, June 11, 2013 10:53 AM
    • Marked as answer by Texeco Tuesday, June 11, 2013 4:41 PM
    Tuesday, June 11, 2013 10:53 AM
  • Thanks Richard,

    I don't know why, but when I first started trying it, it wasn't working. Just wasn't returning any results. Now everything seems to be working

    Tuesday, June 11, 2013 4:46 PM