locked
Project build error: Could not load Microsoft.SqlServer.Types, Version 14.0.0.0. The loaded assembly's manifest definition does not match the assembly reference. RRS feed

  • Question

  • User-173333858 posted

    I am trying to compile my ASp project and it keeps giving me this error. I tried installing a lower version of Microsoft.SqlServer.Types, but it cannot be installed since there are ReportViewer dependencies. Does anyone have any suggestions? My web.config file has Microsoft.SqlServer.Types version 11.0.0.0, but not sure what to change to make the 2 compatible.

    Thanks!

    Friday, November 15, 2019 2:23 AM

Answers

  • User-173333858 posted

    Hi YongQing,

    I actually uninstalled and then re- installed some Nuget Packages related to ReportViewer that were also included. That solved this error. I think it needed a different version.

    Thanks though!

    -Rashmi

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, November 18, 2019 8:19 PM

All replies

  • User665608656 posted

    Hi RDesh,

    I am trying to compile my ASp project and it keeps giving me this error. I tried installing a lower version of Microsoft.SqlServer.Types, but it cannot be installed since there are ReportViewer dependencies. Does anyone have any suggestions? My web.config file has Microsoft.SqlServer.Types version 11.0.0.0, but not sure what to change to make the 2 compatible.

    According to your description,  this is one of the common solutions.

    You can select the currently conflicting dll reference, right-click the reference, select the property, and change the Specific Version option to false.

    If this doesn't solve your issue, you can try other solutions. Here is a discussion about this issue, and there are many other solutions in it.

    The located assembly's manifest definition does not match the assembly reference

    Best Regards,

    YongQing.

    Monday, November 18, 2019 7:31 AM
  • User-173333858 posted

    Hi YongQing,

    I actually uninstalled and then re- installed some Nuget Packages related to ReportViewer that were also included. That solved this error. I think it needed a different version.

    Thanks though!

    -Rashmi

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, November 18, 2019 8:19 PM