locked
Outlook starts with delay if add in is installed RRS feed

  • Question

  • Hi folks!

    I have developed an Outlook 2007 AddIn with Visual Basic 2008 and VSTO 3.0. The AddIn works fine but if I install the AddIn on a machine in a domain that has no access to the internet Outlook needs more than 30 seconds to start. This behaviour is the same as often as I start Outlook. No matter if I just restarted this machine.

    I did some tests and here are my results:

    I set up the LoadBehaviour value to 9. Then Outlook immediately starts because my AddIn is not loaded at this time. But when I open the Actions menu the

    AddIn will be loaded to show the menu item "New: MyAddIn". Thus Outlook hangs for about 30 seconds and than opens the menu - my AddIn is successfully loaded

    and works fine. I plug off the network cable and redo this test and the AddIn is immediately loaded.

    Well, what is going on? What can I do to avoid this hanging time?

    Thanks

    Mõbius

    Wednesday, March 25, 2009 3:03 PM

Answers

  • Hi at all,

    I just found the solution.

    At the project properties page of my AddIn project on the "publish" tab there is a button called "updates". I just set up the option "Never search for updates" and the startup delay disappeared. I thought I already disabled that option but I obviousely did not.

    So by unchecking the above mentioned option in Internet Explorer and disabling the search for updates in Visual Studio the problem is completely solved.

    Thanks to all who helped me.

    Mõbius
    • Marked as answer by Mõbius Thursday, April 9, 2009 8:38 AM
    Thursday, April 9, 2009 8:36 AM

All replies

  • Hi,

    Does any of your code involved network based function? Or this might caused by anti-virus software which hold your request to check the security.

    Can you reproduce this issue in your develop machine?

    Thanks
    We have published a VSTO FAQ recently, you can view them from the entry thread VSTO FAQ.
    If you have any feedbacks or suggestions on this FAQ, please feel free to write us emails to colbertz@microsoft.com.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, March 30, 2009 9:05 AM
  • Hi,

    yes it does. But only using other libraries. So I already cleaned up my code of using these libraries. But the appearence is the same.

    On my developing machine I cannot reproduce that issue. But I did some tests with a virtual domain environment. This has no connection to the internet. There I could reproduce the described behaviour of my customer.

    Another difference between my developing machine and the customer computer is that he has no Exchange server. I read on the internet about problems while using some Exchange objects. The described appearance sounds very familiar to my issue. But I do not use any Exchange objects.

    Still another idea I had was the signature of my AddIn. This is at the moment a self signed certificate. Because I found out that Outlook is contacting www.download.microsoft.com and crl.microsoft.com during that 30 seconds delay. Is there any connection between the described behaviour?

    Thanks

    Mõbius
    Monday, March 30, 2009 1:18 PM
  • Hello,

    Thanks for your information, I've found some clew in this KB article:
    http://support.microsoft.com/kb/944752/en-us

  • When the Microsoft .NET Framework 2.0 loads a managed assembly, the managed assembly calls the CryptoAPI function to verify the Authenticode signature on the assembly files to generate publisher evidence for the managed assembly.
  • The CryptoAPI function checks a Certificate Revocation List (CRL) that is available at http://crl.microsoft.com. This action requires an Internet connection.
  • So, if you are using certification to sign your solution this may a possible cause of your issue, to work this around we need to modify a security setting of IE,please follow below steps:
    IE Tools Menu->Advansed tab->Security section->uncheck "Check for Publisher's Certificate Revocation".

    another way to work this around:
    We could use a Config file to disable this option,please refer to this KB article:
    http://support.microsoft.com/kb/936707/en-us

    Here are some related topics:
    http://sha-dng-03/ReviewSystem/TabView.aspx?open_flag=2&PostId=43396819
    http://social.msdn.microsoft.com/Forums/en-US/vbgeneral/thread/d303523f-217c-46f8-b3c2-763864f97b52/

    Thanks


    We have published a VSTO FAQ recently, you can view them from the entry thread VSTO FAQ.
    If you have any feedbacks or suggestions on this FAQ, please feel free to write us emails to colbertz@microsoft.com.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
Tuesday, March 31, 2009 9:33 AM
  • Hi, thanks for your post. I tried configuring my config file and crl.microsoft.com is no more contacted but the delay did not change. So I additionally unchecked the mentioned setting in IE and now the delay is about the half. But in the last half Outlook is contacting www.download.microsoft.com and it is only doing this when loading my AddIn. I just tested with adding a new entry to my hosts file pointing this url to a local IP but no changes. I also could not find any way to completely disable Microsoft Updates for Office. I know there may be an option on the windows update site but remember the customer computer has no internet connection. Any more ideas? Mõbius
    Wednesday, April 1, 2009 6:37 AM
  • Hi at all,

    I just found the solution.

    At the project properties page of my AddIn project on the "publish" tab there is a button called "updates". I just set up the option "Never search for updates" and the startup delay disappeared. I thought I already disabled that option but I obviousely did not.

    So by unchecking the above mentioned option in Internet Explorer and disabling the search for updates in Visual Studio the problem is completely solved.

    Thanks to all who helped me.

    Mõbius
    • Marked as answer by Mõbius Thursday, April 9, 2009 8:38 AM
    Thursday, April 9, 2009 8:36 AM