The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure App Service - Web Apps!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Adding SSL Results in HTTP Error 502.5 - Process Failure (ASP.NET Core 2.0) RRS feed

  • Question

  • Hey everyone,

    As the title suggests, my website (http://dwitchcord.com) has been running without any issues until just a few minutes ago when I went through the Azure portal to create and bind an SSL cert. That process was quick and painless, but then I went to view my website in a browser and saw this page (see below).

    Note that every request now results in this same exact error message!

    I had also enabled the "HTTPS Only" feature, and thought it might have been related, but disabling it didn't seem to help either.

    Any help would be appreciated. Thanks!

    Sincerely,
    Dave Sexton

    HTTP Error 502.5 - Process Failure

    <fieldset>

    Common causes of this issue:

    • The application process failed to start
    • The application process started but then stopped
    • The application process started but failed to listen on the configured port
    </fieldset>
    <fieldset>

    Troubleshooting steps:

    • Check the system event log for error messages
    • Enable logging the application process' stdout messages
    • Attach a debugger to the application process and inspect
    </fieldset><fieldset>

    For more information visit: <cite>https://go.microsoft.com/fwlink/?LinkID=808681 </cite>

    </fieldset>


    http://davesexton.com/blog

    Sunday, June 3, 2018 5:38 PM

Answers

  • Okay, it finally works!

    Solution: I changed the SSL bindings from SNI SSL to IP SSL.

    I don't know for sure why IP SSL is necessary, but apparently it is. I suspect it might be because I'm using an A record rather than CNAME.

    Important note for anyone else coming across this post:
    If you choose IP SSL, then you may have to change the IP address to which your A record points. In my case I didn't, but you should check anyway. According to the Azure documentation, the external IP address is shown under the Hostnames section of the Custom Domains page (for me, this page is right above the SSL settings page in the navigation links at the left side margin.)


    http://davesexton.com/blog

    • Marked as answer by Dave Sexton Monday, June 4, 2018 9:16 PM
    Monday, June 4, 2018 9:16 PM

All replies

  • I'm still having the same problem after deleting and republishing the root website app files (e.g., all of the .dll files under wwwroot) per the recommendation in the following blog post.

    https://developers.de/blogs/damir_dobric/archive/2017/09/14/asp-net-core-issue-http-error-502-5.aspx 


    http://davesexton.com/blog

    Sunday, June 3, 2018 6:59 PM
  • Note that this is not an upgrade from ASP.NET Core 1.x to ASP.NET Core 2.0. The site was built on ASP.NET Core 2.0 when I first started working on it a couple of weeks ago. This is the first time I'm seeing this 502 error and it happened immediately after I had bound the SSL cert to my host name through the Azure portal.


    http://davesexton.com/blog

    Sunday, June 3, 2018 7:00 PM
  • I will suggest you re-examine your X509Certificate and check if your Azure SSL certificate is properly stored. If there is any miss on any of these it results in error 502.5.

    Monday, June 4, 2018 3:06 AM
  • Okay thanks, I'm not sure how to check - the Azure portal walked me through the entire process. But I'll see what I can do.

    Thanks!


    http://davesexton.com/blog

    Monday, June 4, 2018 3:19 AM
  • I removed the SSL bindings and I'm still getting the 502.5 error. Perhaps adding the SSL bindings in the first place has corrupted my app service somehow? I have no idea what/where to check and how I can fix this on my own.

    Azure walked me through the entire process so I don't know how I could have messed anything up myself. I bought the cert through Azure, so I don't have a copy of it to examine. Azure walked me through placing it into a "key store" (EDIT: "key vault"). I don't know what/where that is or how to check that it worked correctly. Azure also helped me choose the correct bindings. It populated all the dropdowns with the relevant certs.

    Any further advice is appreciated!

    Thanks,


    http://davesexton.com/blog


    Monday, June 4, 2018 3:59 AM
  • Okay I found the Key Vault, but strangely under Certificates it's empty. It looks like it put the cert under "Secrets". Does that sound correct to you?

    Thanks.


    http://davesexton.com/blog

    Monday, June 4, 2018 4:07 AM
  • Yes, you need to add your SSL certificate to key vault secrets.
    Refer to this link for details and step by step guide on Buy and Configure an SSL Certificate for your Azure App Service
    Monday, June 4, 2018 6:45 AM
  • Thank you, but I have already followed those instructions. One thing that stands out, though, is that I chose SNI SSL as recommended, but I think I'm using an A record. Maybe that's the problem? There is supposed to be an "Advanced" section to that document, but it's missing!

    Thanks,
    Dave


    http://davesexton.com/blog

    Monday, June 4, 2018 3:57 PM
  • But wait, none of this matters though - like I said, I've already removed the SSL bindings and my site is still not working. I'm getting a 502 error even without SSL.

    So it looks like Azure has messed up some kind of internal configuration. Now what can I do? My site has been down for almost 24 hours now and I don't see how it's anything that I caused!

    Thanks,
    Dave


    http://davesexton.com/blog

    Monday, June 4, 2018 4:32 PM
  • I removed and re-added the SSL bindings, but I'm still having the same issue.

    Can somebody from Azure please look into this? It seems that my website has been corrupted somehow and there's no indication of what might be the cause. My application was working, then I followed the Azure instructions to buy and configure an SSL cert, and now my website is no longer working. It's not even working if I remove the SSL bindings. I also deleted the .dlls and web.config file from the site and republished them, but it hasn't changed anything.

    I'm desperate now, because my website has been down for over 24 hours.

    Thanks,
    Dave Sexton


    http://davesexton.com/blog

    Monday, June 4, 2018 9:02 PM
  • Okay, it finally works!

    Solution: I changed the SSL bindings from SNI SSL to IP SSL.

    I don't know for sure why IP SSL is necessary, but apparently it is. I suspect it might be because I'm using an A record rather than CNAME.

    Important note for anyone else coming across this post:
    If you choose IP SSL, then you may have to change the IP address to which your A record points. In my case I didn't, but you should check anyway. According to the Azure documentation, the external IP address is shown under the Hostnames section of the Custom Domains page (for me, this page is right above the SSL settings page in the navigation links at the left side margin.)


    http://davesexton.com/blog

    • Marked as answer by Dave Sexton Monday, June 4, 2018 9:16 PM
    Monday, June 4, 2018 9:16 PM
  • Glad to know that issue got resolved 
    Tuesday, June 5, 2018 2:40 AM