none
Creating a new Form Document from Microsoft Edge fails when the form needs InfoPath Filler.

    Question

  • I am trying to create a new document in a form Library but Microsoft Edge and other browsers are failing to open the local InfoPath Filler application, IE works but no others.

    Workflow:

    On a Form Library in SharePoint 2013 using Edge as the browser clicking new document fails as Edge is trying to open the form in the web page, but because my form has custom code it will only work / open using the installed InfoPath form filler 2013.

    This is highly frustrating when using links in emails to edit these forms as Windows 10 defaults to Edge and of course again they refuse to open in the Web.

    Does anyone know why this is the behaviour of Edge can it be changed or does anyone have a work around?

    Any help would be greatly appreciated,

    Luke


    • Edited by Luke Newman Thursday, April 13, 2017 10:25 AM
    Thursday, April 13, 2017 10:24 AM

All replies

  • Is there any specific requirement to run only on Edge. Because, SharePoint is sync yet with IE edge. Even IE 11 also not completely Sync. See the note in below blog

    https://technet.microsoft.com/en-us/library/cc263526.aspx

    "Internet Explorer 11 edge mode is not supported. Add sites to the Compatibility View list to make some features work."

    Did you have enterprise mode in Edge. If so, then change to enterprise mode and test (Tools-> Enterprise mode)

    ----------------------------------------------------------------------------

    Thanks

    Lalith

    ----------------------------------------

    Please mark as Answer, if this post solves your issue.


    • Proposed as answer by croute1 Thursday, April 13, 2017 2:56 PM
    Thursday, April 13, 2017 12:02 PM