none
DHCP Allocator in CE 6.0 RRS feed

  • Question

  • Hello MSDN,

    I'm tryng to implement a simple DHCP server on WIN CE 6.0.

    My target is to connect a Wince device to a normal PC.

    I implemented DHCP allocator as follow (my ethernet port is a USB-ethernet cable):

     

    [HKEY_LOCAL_MACHINE\Comm\mosusbce1\Parms\TCPIP]
    "AutoCfg"=dword:0
    "EnableDHCP"=dword:0
    "DefaultGateway"="0.0.0.0"
    "IpAddress"="192.168.0.1"
    "Subnetmask"="255.255.255.0"

    [HKEY_LOCAL_MACHINE\Comm\ConnectionSharing]
    "EnableDhcpAllocator"=dword:1
    "PrivateInterface"="mosusbce1"
    "DhcpAllocationStartRange"="2"
    "DhcpAllocationEndRange"="10"
    "EnableDnsProxy"=dword:1
    "EnablePacketFiltering"=dword:0
    "DHCPLeaseTime"=dword:300

    But PC is not able to acquire an address.

    in WireShark I see packet DHCP Discover not answered.

    I copied code from internet, and they say it works...

    maybe I miss some component in PB ?

    thanks in advance

     

    Mirko

     

     


    Mirko Tacconi
    Friday, July 8, 2011 3:40 PM

Answers

  • OK. I solved the problem myself!

    I missed the component in Platform Builder "Reference Gateway".

    Thanks the same !

     

    Mirko


    Mirko Tacconi
    • Marked as answer by Jesse Jiang Tuesday, July 12, 2011 6:45 AM
    Monday, July 11, 2011 9:56 AM

All replies

  • OK. I solved the problem myself!

    I missed the component in Platform Builder "Reference Gateway".

    Thanks the same !

     

    Mirko


    Mirko Tacconi
    • Marked as answer by Jesse Jiang Tuesday, July 12, 2011 6:45 AM
    Monday, July 11, 2011 9:56 AM
  • Thanks you for sharing the solution.

     

    Best regards,

    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, July 12, 2011 6:45 AM
  • Hello MSDN,

    I'm tryng to implement a simple DHCP server using the DHCP allocator on WIN CE 6.0.

    My target is to create a adhoc network using DHCP and connect an iphone to it and want the DNS and Default gateway to set to 0.0.0.0. 

    I implemented DHCP allocator as follow

     

    [HKEY_LOCAL_MACHINE\Comm\RT24801\Parms\TCPIP]
    "AutoCfg"=dword:0
    "EnableDHCP"=dword:0
    "DefaultGateway"="0.0.0.0"
    "IpAddress"="192.168.0.1"
    "Subnetmask"="255.255.255.0"

    [HKEY_LOCAL_MACHINE\Comm\ConnectionSharing]
    "EnableDhcpAllocator"=dword:1
    "PrivateInterface"="RT24801"
    "DhcpAllocationStartRange"="2"
    "DhcpAllocationEndRange"="10"
    "EnableDnsProxy"=dword:1
    "EnablePacketFiltering"=dword:0
    "DHCPLeaseTime"=dword:300

    Iphone connects but, default gateway is set as 192.168.0.1 instead of 0.0.0.0

    I copied code from internet, and they say it works...

    maybe I miss some component ?

    thanks in advance

    Monday, December 5, 2016 3:11 AM