none
aspnet_wp.exe does not exist RRS feed

  • Question

  • Recently the aspnet_wp.exe does not exist in my pc, I have try the execute command "aspnet_regiis -i".

    I also try use iisrest /stop iisreset /start, still does not work.

    does someone met such problem before?

    thanks.

    PS:my os is windows xp sp3.

    Tuesday, April 3, 2012 8:24 AM

Answers

All replies

  • hi,

    you can find aspnet_regiis.exe in below location

    Framework 2

    c:\windows\Microsoft.Net\FrameWork\v2.0.50727

    Framework 4

    c:\windows\Microsoft.Net\FrameWork\v4.0.30319

    you can not find aspnet_regiis in framework 3 or 3.5

    Regards

    Anand

    Tuesday, April 3, 2012 9:36 AM
  • aspnet_wp.exe is related to IIS 5.0 version which handles the request. If you have IIS 6.0 and above it would be w3wp.exe that handles the incoming request.

    Rajesh S V

    Tuesday, April 3, 2012 11:10 AM
  • Hi Rajesh,

    My IIS version is 5.1. so it should be aspnet_wp.exe.

    Thursday, April 5, 2012 1:06 AM
  • Hi Anand,

    Both Framework 2 and Framework 4 are installed in my PC.

    Thanks.

    Thursday, April 5, 2012 1:09 AM
  • Did you install then before you installed IIS or after?
    Thursday, April 5, 2012 3:12 AM
  • Hi Shaun Wilde,

    I forgot if I installed IIS before install .net framework or after that?

    Should I reinstall IIS ?

    Thursday, April 5, 2012 8:22 AM
  • Hi, 

    If I am not wrong Vista and Windows 7 comes with .net framework version 2.0 and 3.0 but with XP no pre installed framework comes. 

    So for your case I would suggest re-install IIS. 


    If this post answers your question, please click "Mark As Answer". If this post is helpful please click "Mark as Helpful".

    Thursday, April 5, 2012 8:47 AM
  • Hi Kris444,

    I re-install the IIS and reg iis with  but still do not work, and the first time i run aspnet_regiis, got the "Executing inf section: AdminService.Uninstall: InstallInfSections failed with HRESULT 8007041f: 'The service database is locked." error, and i try to run aspnet_regiis again, no such error.

    Thanks.

    Thursday, April 5, 2012 9:45 AM
  • Hi Anand,

    we can find aspnet_regiis on framework 3.5 also. Please check this:

    http://msdn.microsoft.com/en-us/library/k6h9cz8h(v=vs.90).aspx


    Regards, http://shwetamannjain.blogspot.com

    Saturday, April 7, 2012 5:10 PM
  • Hi Wozniak,

    Please reinstall .Net framework n SDK, it will fix your problem.


    Regards, http://shwetamannjain.blogspot.com

    Saturday, April 7, 2012 5:15 PM