none
Problem with third party .dll not loading in x64, .net 4.0 RRS feed

  • Question

  • I am responsible for development of an n-tier application used to process photo images for large scale printing on canvas and paper.  There is a third party .dll (Aurigma.GraphicsMill) that I need to call in order to set rendering intent and embed an icc profile in a bitmap image.

    The .dll works just fine in a simple console or windows forms app.  When I try and add it to my larger project it gives me the following error after attempting to build the solution.

    Error 10 An attempt was made to load an assembly with an incorrect format: C:\Users\dhoffman\Documents\Visual Studio 2012\Projects\CanvasPrinter\CGCanvasPrinter\bin\x64\Release\Aurigma.GraphicsMill.dll. C:\Users\dhoffman\Documents\Visual Studio 2012\Projects\CanvasPrinter\CGCanvasPrinter.Domain\SGEN CGCanvasPrinter.Domain

    This solution is made up of three separate projects.  Ironically I can add this reference to two of the three but not to the one that I need (the business logic tier).  The whole solution is set to compile for x64 using .net 4.0.  It must be in x64 because it uses a lot of memory to manipulate the large graphics files.

    I have the project zipped up if you would like me to submit it for testing.  Didn't see any way to attach it to this communication.

    I have tried numerous things that I've found on the web but none of them have worked.  Hopefully someone there can help.

    Thank you - Dale Hoffman

    Friday, January 11, 2013 9:42 PM

Answers

All replies