locked
Slow test performance RRS feed

  • Question

  • Running VS2012 with a Web API based solution. 3 projects (server, tests, wix installer).

    I press CTRL+R+T to run the current test and it literally takes 30 seconds of symbol loading before I can actually debug/step into my test.

    What am I doing wrong?  Never had this issue in VS2010.

    Tuesday, September 18, 2012 8:22 PM

Answers

  • Hello Scott_m,

    It is maybe trying to break at an exception that is thrown from the .Net framework code.

    Firstly you should make sure that you unchecked the only symbol file location (Microsoft Symbol Servers). If so, then you can try Tools->Options->Debugging and then check Enable Just My Code to see if it helps.

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by scott_m Thursday, September 20, 2012 4:39 AM
    Thursday, September 20, 2012 2:37 AM

All replies

  • Hello Scott_m,

    Thank you for posting in the MSDN forum.

    I would like to know what your scenario is in your solution. Whether there are many tests in your project or not? After 30 seconds of loading, can you debug/step into your test successfully?

    I have tried this operation in VS2010.  When many projects and test projects with many tests are in one solution, it also actually takes long time to load before debugging.

    In addition, you can create a simple test project with a simple test and press Ctrl+R+T to run the current test to check if it helps.

    I hope it can help you.

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, September 19, 2012 4:08 AM
  • Solution Contents (It's fairly small)

    1. 1 .NET 4.0 WebAPI SelfHosted Project 

    2. 1 Unit Test project consisting of 3 test classes

    3. 1 Wix Installer project


    The tests do eventually run.  It just takes 30 seconds worth of loading DLL's before hand.  Note, I am running on Windows 2008 Server R2.  My co-worker has the same code running on Windows 8 and does not experience this issue.

    Wednesday, September 19, 2012 2:10 PM
  • Hello Scott_m,

    As my previous reply, you can try to work with only a unit test projects including 3 test classes to see if the problem still will occur. Then you can create another solution about three different projects for example class library, unit test and web test projects to check if it helps.

    If still no help, you can try the following steps to see if it helps:

    a) Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b) Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems.

    c) Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not.

    I hope this will be helpful to you.

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, September 20, 2012 12:54 AM
  • Hello Scott_m,

    As my previous reply, you can try to work with only a unit test projects including 3 test classes to see if the problem still will occur. Then you can create another solution about three different projects for example class library, unit test and web test projects to check if it helps.

    If still no help, you can try the following steps to see if it helps:

    a) Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b) Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems.

    c) Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not.

    I hope this will be helpful to you.

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us

    I added a new test project with one unit test class and one test method.  On this project I get a dialogue that shows "Downloading public symbols" for each dll.  It is very slow.  I do not get this dialogue on my other unit test project.  How do I disable downloading of public symbols when debugging unit test?

    Thursday, September 20, 2012 2:19 AM
  • Hello Scott_m,

    It is maybe trying to break at an exception that is thrown from the .Net framework code.

    Firstly you should make sure that you unchecked the only symbol file location (Microsoft Symbol Servers). If so, then you can try Tools->Options->Debugging and then check Enable Just My Code to see if it helps.

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by scott_m Thursday, September 20, 2012 4:39 AM
    Thursday, September 20, 2012 2:37 AM