none
Failed to initialize Kinect Fusion reconstruction volume on device-1 RRS feed

Answers

All replies

  • your GPU might not be supported , http://msdn.microsoft.com/en-us/library/dn188670.aspx ,

    in the code you have to change it to CPU and compile the application again,

    but it will be very slowly.

    Tuesday, March 19, 2013 3:16 PM
  • Specifically, your graphics hardware must support DirectX 11 in order to run Kinect Fusion with GPU acceleration.


    John | Kinect for Windows development team

    Wednesday, March 20, 2013 12:58 AM
  • I have DX 11 installed and am still havving issues, i put it down to being a mobile GPU rig

    ---------------
    Display Devices
    ---------------
              Card name: NVIDIA GeForce GT 230M
           Manufacturer: NVIDIA
              Chip type: GeForce GT 230M
               DAC type: Integrated RAMDAC
             Device Key: Enum\PCI\VEN_10DE&DEV_0A28&SUBSYS_363E103C&REV_A2
         Display Memory: 2253 MB
       Dedicated Memory: 978 MB
          Shared Memory: 1275 MB
           Current Mode: 1366 x 768 (32 bit) (60Hz)
           Monitor Name: Generic PnP Monitor
          Monitor Model: unknown
             Monitor Id: SEC3651
            Native Mode: 1366 x 768(p) (60.031Hz)
            Output Type: Internal
            Driver Name: nvd3dum.dll,nvwgf2um.dll,nvwgf2um.dll
    Driver File Version: 8.17.0013.0142 (English)
         Driver Version: 8.17.13.142
            DDI Version: 10.1
           Driver Model: WDDM 1.1
      Driver Attributes: Final Retail

    Thursday, March 21, 2013 6:36 AM
  • Hy!

    @arctorx: "in the code you have to change it to CPU and compile the application again?"

    Where do have to edit the code? (Basic Example)

    Thanks

    Thursday, March 21, 2013 12:43 PM
  • I guess I have to edit the following line:

     // This parameter sets whether GPU or CPU processing is used. Note that the CPU will likely be 
     // too slow for real-time processing.
     m_processorType = NUI_FUSION_RECONSTRUCTION_PROCESSOR_TYPE_AMP;

    Thursday, March 21, 2013 12:48 PM
  • Yes that solved  my first problem:

    m_processorType = NUI_FUSION_RECONSTRUCTION_PROCESSOR_TYPE_CPU;

    Thursday, March 21, 2013 1:10 PM
  • Patrik,

    I am not a developer, but I would like to try out Kinect Fusion.  Unfortunately my GPU also does not meet the minimum requirements.

    Would you mind descrbing how and where to edit the code to make the switch.

    Thanks!

    Friday, April 12, 2013 11:09 PM