locked
Switching Between Input Languages: System-wide vs. Application-specific

    Question

  • I installed additional keyboard layouts on the Windows 8 system. Unlike Windows 7, where switching to a different keyboard layout would only take place in the current application, switching keyboard layouts under Windows 8 is system-wide and persists across all applications. Is there a way to change this behavior?
    Wednesday, October 19, 2011 11:22 PM

Answers

  • had the same problem. to solve it:

    1. go into desktop view

    2. left-click on the little language indicator at the right hand side of the task bar and choose "Change language preferences"

    3. on the left of the window that pops up, click "Advanced Settings" 

    4. and finally, under "Switching input language" tick the checkbox for "Let me set a different input language for each app window"

    5. click "Save" and you are done.

     

    PS: Thanks for asking that question. I was constantly annoyed by it, but never actually questioned that this is the new behavior of Windows 8. And only after your question I started looking ;-)

    • Proposed as answer by Exotic Hadron Thursday, October 20, 2011 9:08 AM
    • Marked as answer by Vadim Klishko Thursday, October 20, 2011 5:53 PM
    Thursday, October 20, 2011 6:57 AM

All replies

  • had the same problem. to solve it:

    1. go into desktop view

    2. left-click on the little language indicator at the right hand side of the task bar and choose "Change language preferences"

    3. on the left of the window that pops up, click "Advanced Settings" 

    4. and finally, under "Switching input language" tick the checkbox for "Let me set a different input language for each app window"

    5. click "Save" and you are done.

     

    PS: Thanks for asking that question. I was constantly annoyed by it, but never actually questioned that this is the new behavior of Windows 8. And only after your question I started looking ;-)

    • Proposed as answer by Exotic Hadron Thursday, October 20, 2011 9:08 AM
    • Marked as answer by Vadim Klishko Thursday, October 20, 2011 5:53 PM
    Thursday, October 20, 2011 6:57 AM
  • Merci beaucoup, plot-paris !

    They do know how to hide some features!

     


    Вадим Клішко
    Thursday, October 20, 2011 5:55 PM